8a86b50092
Fix build failure raised since commit
810ba387be
by disabling SSP when needed
Fixes:
- https://gitlab.com/kubu93/buildroot/-/jobs/1247043361
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Reviewed-by: Alexander Egorenkov <egorenar@linux.ibm.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
48 lines
2.1 KiB
Diff
48 lines
2.1 KiB
Diff
From 8a054081678ed0b0e56f829bac0a4656e3a198b9 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sat, 8 May 2021 22:03:11 +0200
|
|
Subject: [PATCH] arch/s390: disable SSP when needed
|
|
|
|
Though -nostdlib is passed in PURGATORY_LDFLAGS and -ffreestanding in
|
|
KBUILD_CFLAGS_DECOMPRESSOR, -fno-stack-protector must also be passed to
|
|
avoid linking errors related to undefined references to
|
|
'__stack_chk_guard' and '__stack_chk_fail' if toolchain enforces
|
|
-fstack-protector.
|
|
|
|
Fixes:
|
|
- https://gitlab.com/kubu93/buildroot/-/jobs/1247043361
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
arch/s390/Makefile | 1 +
|
|
arch/s390/purgatory/Makefile | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
diff --git a/arch/s390/Makefile b/arch/s390/Makefile
|
|
index e443ed9947bd..098abe3a56f3 100644
|
|
--- a/arch/s390/Makefile
|
|
+++ b/arch/s390/Makefile
|
|
@@ -28,6 +28,7 @@ KBUILD_CFLAGS_DECOMPRESSOR += -DDISABLE_BRANCH_PROFILING -D__NO_FORTIFY
|
|
KBUILD_CFLAGS_DECOMPRESSOR += -fno-delete-null-pointer-checks -msoft-float -mbackchain
|
|
KBUILD_CFLAGS_DECOMPRESSOR += -fno-asynchronous-unwind-tables
|
|
KBUILD_CFLAGS_DECOMPRESSOR += -ffreestanding
|
|
+KBUILD_CFLAGS_DECOMPRESSOR += -fno-stack-protector
|
|
KBUILD_CFLAGS_DECOMPRESSOR += $(call cc-disable-warning, address-of-packed-member)
|
|
KBUILD_CFLAGS_DECOMPRESSOR += $(if $(CONFIG_DEBUG_INFO),-g)
|
|
KBUILD_CFLAGS_DECOMPRESSOR += $(if $(CONFIG_DEBUG_INFO_DWARF4), $(call cc-option, -gdwarf-4,))
|
|
diff --git a/arch/s390/purgatory/Makefile b/arch/s390/purgatory/Makefile
|
|
index c57f8c40e992..21c4ebe29b9a 100644
|
|
--- a/arch/s390/purgatory/Makefile
|
|
+++ b/arch/s390/purgatory/Makefile
|
|
@@ -24,6 +24,7 @@ KBUILD_CFLAGS := -fno-strict-aliasing -Wall -Wstrict-prototypes
|
|
KBUILD_CFLAGS += -Wno-pointer-sign -Wno-sign-compare
|
|
KBUILD_CFLAGS += -fno-zero-initialized-in-bss -fno-builtin -ffreestanding
|
|
KBUILD_CFLAGS += -c -MD -Os -m64 -msoft-float -fno-common
|
|
+KBUILD_CFLAGS += -fno-stack-protector
|
|
KBUILD_CFLAGS += $(CLANG_FLAGS)
|
|
KBUILD_CFLAGS += $(call cc-option,-fno-PIE)
|
|
KBUILD_AFLAGS := $(filter-out -DCC_USING_EXPOLINE,$(KBUILD_AFLAGS))
|
|
--
|
|
2.30.2
|
|
|