18199aa7b6
They will be applied ONLY if BR2_KERNEL_HEADERS_LZMA is set. BR2_KERNEL_HEADERS_LZMA defaults to NO, so the user has to actively set this config flag if lzma is needed. This means that the default behaviour of buildroot will work for most users. Comment from author: [Brad House] I find myself having to remove the lzma patches because my build system doesn't natively have lzma. I tried to compensate for this by installing the latest lzma from gentoo's package tree, and apparently, it accepts different flags than the one these patches expect, so my kernel build still fails. Finally, I used the lzma from this buildroot and compiled it by hand, and it _mostly_ worked. Regardless, it seems silly to make this a requirement. Personally, I gzip my initramfs, and that's enough compression for me...
55 lines
2.1 KiB
Diff
55 lines
2.1 KiB
Diff
diff -rdup linux-2.6.21.5.oorig/arch/i386/boot/compressed/Makefile linux-2.6.21.5/arch/i386/boot/compressed/Makefile
|
|
--- linux-2.6.21.5.oorig/arch/i386/boot/compressed/Makefile 2007-07-24 13:08:51.000000000 +0200
|
|
+++ linux-2.6.21.5/arch/i386/boot/compressed/Makefile 2007-07-24 14:54:38.000000000 +0200
|
|
@@ -4,7 +4,7 @@
|
|
# create a compressed vmlinux image from the original vmlinux
|
|
#
|
|
|
|
-tragets := head.o lzma_misc.o piggy.o \
|
|
+targets := head.o lzma_misc.o piggy.o \
|
|
vmlinux.bin.all vmlinux.relocs \
|
|
vmlinux vmlinux.bin vmlinux.bin.gz
|
|
EXTRA_AFLAGS := -traditional
|
|
diff -rdup linux-2.6.21.5.oorig/scripts/gen_lzma_initramfs_list.sh linux-2.6.21.5/scripts/gen_lzma_initramfs_list.sh
|
|
--- linux-2.6.21.5.oorig/scripts/gen_lzma_initramfs_list.sh 2007-07-24 13:08:51.000000000 +0200
|
|
+++ linux-2.6.21.5/scripts/gen_lzma_initramfs_list.sh 2007-07-24 15:12:10.000000000 +0200
|
|
@@ -253,7 +253,7 @@ while [ $# -gt 0 ]; do
|
|
shift
|
|
;;
|
|
"-s")
|
|
- opt="-d16"
|
|
+ #opt="-d16" ? what was that supposed to do?
|
|
;;
|
|
"-d") # display default initramfs list
|
|
default_list="$arg"
|
|
@@ -286,7 +286,7 @@ if [ ! -z ${output_file} ]; then
|
|
cpio_tfile=${cpio_file}
|
|
fi
|
|
rm ${cpio_list}
|
|
- lzma e ${cpio_tfile} ${output_file} ${opt}
|
|
+ lzma -z ${cpio_tfile} ${opt} -c > ${output_file}
|
|
[ -z ${cpio_file} ] && rm ${cpio_tfile}
|
|
fi
|
|
exit 0
|
|
--- linux-2.6.21.5.oorig/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 15:24:44.000000000 +0200
|
|
+++ linux-2.6.21.5/arch/i386/boot/compressed/lzma_misc.c 2007-07-24 17:09:40.000000000 +0200
|
|
@@ -241,7 +241,6 @@ static int lzma_unzip(uch* output)
|
|
|
|
static int read_byte(void *object, const unsigned char **buffer, SizeT *bufferSize)
|
|
{
|
|
- static unsigned int i = 0;
|
|
static unsigned char val;
|
|
*bufferSize = 1;
|
|
val = get_byte();
|
|
--- linux-2.6.21.5.oorig/scripts/Makefile.lib 2007-07-24 15:24:44.000000000 +0200
|
|
+++ linux-2.6.21.5/scripts/Makefile.lib 2007-07-24 18:03:57.000000000 +0200
|
|
@@ -165,6 +165,7 @@ cmd_gzip = gzip -f -9 < $< > $@
|
|
# LZMA
|
|
#
|
|
quiet_cmd_lzma = LZMA $@
|
|
-cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
|
|
+#cmd_lzma = lzma e $< $@ -lc7 -lp0 -pb0 2>/dev/null
|
|
+cmd_lzma = lzma -z $< -c > $@
|
|
|
|
|