0a5ec78866
Fix install into staging (YES instead of yes), fix uninstall target, use default target-install handling, install headers/lib/man pages into target if requested. A small patch is needed for 'make remove' to work. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
23 lines
686 B
Diff
23 lines
686 B
Diff
[PATCH]: dmraid: fix make remove for header files
|
|
|
|
prefix/include/dmraid is not empty, so we need rm -rf
|
|
|
|
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
|
---
|
|
1.0.0.rc15/include/Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
Index: dmraid/1.0.0.rc15/include/Makefile.in
|
|
===================================================================
|
|
--- dmraid.orig/1.0.0.rc15/include/Makefile.in
|
|
+++ dmraid/1.0.0.rc15/include/Makefile.in
|
|
@@ -24,7 +24,7 @@ install: install_dmraid_headers
|
|
|
|
remove_dmraid_headers:
|
|
@echo "Removing $(HEADERS) from $(includedir)/dmraid"
|
|
- rm -f $(includedir)/dmraid
|
|
+ rm -rf $(includedir)/dmraid
|
|
|
|
remove: remove_dmraid_headers
|
|
|