f6f0e1e581
libest is a C implementation of RFC 7030 (Enrollment over Secure Transport). It can be used to provision public key certificates from a certificate authority (CA) or registration authority (RA) to end-user devices and network infrastructure devices. https://github.com/cisco/libest Notes on patches included in this package: - libest bundles a stubbed version of libsafec, and has no provision to build against a system-installed full (non-stubbed) libsafec. We add a patch to make that possible. - Added a configuration option --{enable,disable}-examples to toggle examples build by a separate patch. - There's a configuration option `--enable-jni` which allows to build a JNI library for binding libest to Java programs. And that library would be using an outdated version of OpenSSL 1.0. We fix that by adding support for OpenSSL 1.1 API for that library. - Fixed a bug when specifying either `--enable-FEATURE` or `--disable-FEATURE` has always been enabling the feature. Signed-off-by: Aleksandr Makarov <aleksandr.o.makarov@gmail.com> [Thomas: - Added comments about the upstream status in existing patches - Added a patch fixing an autoreconf issue - Added a patch adding a missing "extern" on a variable to fix build with gcc 10 - Removed the glibc dependency by using the new libexecinfo package - Drastically simplified the complex libcoap disabling and client-only mode vs. OpenJDK issue. libcoap support is now forcefully disabled, and client-mode only option is made invisible when OpenJDK is enabled. - Fixed the license information; - Added missing host-pkgconf ] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From bd4fad5e427f4d2828f2edbe8063f6d6c9276c7b Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Sat, 8 Jan 2022 13:30:58 +0100
|
|
Subject: [PATCH] configure.ac: remove duplicate invocation of AM_INIT_AUTOMAKE
|
|
|
|
autoreconf fails with:
|
|
|
|
configure.ac:9: error: AM_INIT_AUTOMAKE expanded multiple times
|
|
/home/thomas/projets/buildroot/output/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
|
|
configure.ac:7: the top level
|
|
/home/thomas/projets/buildroot/output/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
|
|
configure.ac:9: the top level
|
|
|
|
Drop the duplicate invocation to AM_INIT_AUTOMAKE to solve this.
|
|
|
|
Upstream: https://github.com/cisco/libest/pull/106
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
configure.ac | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0b930bf..66a91f2 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4,7 +4,6 @@ AC_CONFIG_AUX_DIR(config)
|
|
AC_CONFIG_SRCDIR(src/est/est.c)
|
|
AC_CONFIG_MACRO_DIR([m4])
|
|
|
|
-AM_INIT_AUTOMAKE
|
|
AM_MAINTAINER_MODE
|
|
AM_INIT_AUTOMAKE([subdir-objects])
|
|
|
|
--
|
|
2.33.1
|
|
|