dee0cf4181
Backported patch from master branch which implements --disable-tests
configure option, removed original patch 0001, added _CONF_OPTS.
Removed patch 0003, applied upstream:
f1684379df
Added upstream patch to fix musl build.
Tested using this defconfig
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV=y
BR2_PACKAGE_LTRACE=y
BR2_PACKAGE_MESA3D=y
BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST=y
BR2_PACKAGE_MESA3D_OPENGL_EGL=y
BR2_PACKAGE_WESTON=y
BR2_PACKAGE_XORG7=y
BR2_PACKAGE_XSERVER_XORG_SERVER=y
BR2_PACKAGE_LIBJPEG=y
BR2_PACKAGE_LIBUNWIND=y
with test-pkg
armv5-ctng-linux-gnueabi [ 1/49]: OK
armv7-ctng-linux-gnueabihf [ 2/49]: OK
br-aarch64-glibc [ 3/49]: SKIPPED
br-arcle-hs38 [ 4/49]: SKIPPED
br-arm-basic [ 5/49]: SKIPPED
br-arm-cortex-a9-glibc [ 6/49]: OK
br-arm-cortex-a9-musl [ 7/49]: SKIPPED
br-arm-cortex-m4-full [ 8/49]: SKIPPED
br-arm-full [ 9/49]: OK
br-arm-full-nothread [10/49]: SKIPPED
br-arm-full-static [11/49]: SKIPPED
br-bfin-full [12/49]: SKIPPED
br-i386-pentium4-full [13/49]: SKIPPED
br-i386-pentium-mmx-musl [14/49]: SKIPPED
br-m68k-5208-full [15/49]: SKIPPED
br-m68k-68040-full [16/49]: SKIPPED
br-microblazeel-full [17/49]: SKIPPED
br-mips32r6-el-hf-glibc [18/49]: OK
br-mips64-n64-full [19/49]: SKIPPED
br-mips64r6-el-hf-glibc [20/49]: SKIPPED
br-mipsel-o32-full [21/49]: OK
br-nios2-glibc [22/49]: SKIPPED
br-openrisc-uclibc [23/49]: SKIPPED
br-powerpc-603e-basic-cpp [24/49]: SKIPPED
br-powerpc64le-power8-glibc [25/49]: SKIPPED
br-powerpc64-power7-glibc [26/49]: SKIPPED
br-powerpc-e500mc-full [27/49]: SKIPPED
br-sh4-full [28/49]: SKIPPED
br-sparc64-glibc [29/49]: SKIPPED
br-sparc-uclibc [30/49]: SKIPPED
br-x86-64-core2-full [31/49]: OK
br-x86-64-musl [32/49]: SKIPPED
br-xtensa-full [33/49]: SKIPPED
i686-ctng-linux-gnu [34/49]: OK
linaro-aarch64 [35/49]: SKIPPED
linaro-arm [36/49]: OK
mips64el-ctng_n32-linux-gnu [37/49]: SKIPPED
mips64el-ctng_n64-linux-gnu [38/49]: SKIPPED
powerpc-ctng_e500v2-linux-gnuspe [39/49]: OK
sourcery-arm-armv4t [40/49]: OK
sourcery-arm [41/49]: OK
sourcery-arm-thumb2 [42/49]: OK
sourcery-mips64 [43/49]: SKIPPED
sourcery-mips [44/49]: OK
sourcery-nios2 [45/49]: SKIPPED
sourcery-sh [46/49]: SKIPPED
sourcery-x86-64 [47/49]: OK
sourcery-x86 [48/49]: OK
x86_64-ctng_locales-linux-gnu [49/49]: OK
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
69 lines
2.1 KiB
Diff
69 lines
2.1 KiB
Diff
From 208a430bcbab7d63a4c04242f13c4740e0246a56 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=D0=9A=D0=BE=D1=80=D0=BE=D0=BB=D0=B5=D0=B2=20=D0=A1=D0=B5?=
|
|
=?UTF-8?q?=D1=80=D0=B3=D0=B5=D0=B9?= <korolev.sergey@gmail.com>
|
|
Date: Wed, 11 May 2016 22:48:55 +0300
|
|
Subject: [PATCH] add --disable-tests option
|
|
|
|
Allows to skip tests build.
|
|
|
|
Backported from upstream master branch:
|
|
https://github.com/libunwind/libunwind/commit/208a430bcbab7d63a4c04242f13c4740e0246a56
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
Makefile.am | 6 +++++-
|
|
configure.ac | 13 +++++++++++--
|
|
2 files changed, 16 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 6a3ed9e..0c29b3e 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -42,7 +42,11 @@ endif
|
|
|
|
nodist_include_HEADERS = include/libunwind-common.h
|
|
|
|
-SUBDIRS = src tests
|
|
+SUBDIRS = src
|
|
+
|
|
+if CONFIG_TESTS
|
|
+SUBDIRS += tests
|
|
+endif
|
|
|
|
if CONFIG_DOCS
|
|
SUBDIRS += doc
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 863fb8f..6c46cf3 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -129,6 +129,10 @@ AC_ARG_ENABLE(documentation,
|
|
AS_HELP_STRING([--disable-documentation],[Disable generating the man pages]),,
|
|
[enable_documentation=yes])
|
|
|
|
+AC_ARG_ENABLE(tests,
|
|
+ AS_HELP_STRING([--disable-tests],[Disable tests build]),,
|
|
+ [enable_tests=yes])
|
|
+
|
|
AC_MSG_CHECKING([if we should build libunwind-setjmp])
|
|
AC_MSG_RESULT([$enable_setjmp])
|
|
|
|
@@ -396,8 +400,13 @@ if test "x$enable_documentation" = "xyes"; then
|
|
AC_CONFIG_FILES(doc/Makefile doc/common.tex)
|
|
fi
|
|
|
|
-AC_CONFIG_FILES(Makefile src/Makefile tests/Makefile tests/check-namespace.sh
|
|
- include/libunwind-common.h
|
|
+AM_CONDITIONAL([CONFIG_TESTS], [test x$enable_tests = xyes])
|
|
+if test "x$enable_tests" = "xyes"; then
|
|
+ AC_CONFIG_FILES(tests/Makefile tests/check-namespace.sh)
|
|
+fi
|
|
+
|
|
+AC_CONFIG_FILES(Makefile src/Makefile
|
|
+ include/libunwind-common.h
|
|
include/libunwind.h include/tdep/libunwind_i.h)
|
|
AC_CONFIG_FILES(src/unwind/libunwind.pc src/coredump/libunwind-coredump.pc
|
|
src/ptrace/libunwind-ptrace.pc src/setjmp/libunwind-setjmp.pc
|
|
--
|
|
2.11.0
|
|
|