b989436447
While the official upstream has not published any new tarball, they have continued to update their Subversion repository with additional changes. This commit therefore updates the vpnc package to a newer version, using the Github repository that replicates the original Subversion repository. Since the update required some updates to the patches, we took this opportunity to split them in more fine-grained changes, and document them more properly. Consequently: - The patch 0001 that fixes the Makefile gets split into 3 patches, 0001, 0002 and 0003, each for one specific issue. - Patch 0002 to disable building the manpages gets changed into a solution that is potentially upstreamable, and is now patch 0004. - A new patch 0005 is added to specify a custom libgcrypt-config path, since this tool is now used to know how to link with libgcrypt. - The SUSv3 function removal patch is now patch 0006, and gains a better commit log. Also, this vpnc version now depends on gnutls, which basically is a better replacement for OpenSSL, whose support was not enabled by default due to licensing issues (vpnc is under the GPL, which isn't compatible with the OpenSSL license). Patches have been submitted upstream: http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2016-June/004186.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From 8b035de4867db4fb8da41298224d92bf5b18e86f Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 10 Feb 2016 23:27:30 +0100
|
|
Subject: [PATCH] Makefile: allow to override the version
|
|
|
|
The mk-version script makes the assumption that the build process runs
|
|
from a SVN checkout or a Git clone of the vpnc source code. However,
|
|
this is not always the case, for example when you are building from a
|
|
tarball, but inside a larger project that is versioned with Git.
|
|
|
|
This is typically the case when building vpnc under a tool like
|
|
Buildroot, or potentially other embedded Linux build system: the build
|
|
system tool itself is versioned in Git, downloads tarballs of software
|
|
components and builds them.
|
|
|
|
In order to support such situations, this commit adjusts the Makefile
|
|
to allow the VERSION variable to be overriden from the make command
|
|
line.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index f9a6781..e80ef17 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -57,7 +57,7 @@ OBJS = $(addsuffix .o,$(basename $(SRCS)))
|
|
CRYPTO_OBJS = $(addsuffix .o,$(basename $(CRYPTO_SRCS)))
|
|
BINOBJS = $(addsuffix .o,$(BINS))
|
|
BINSRCS = $(addsuffix .c,$(BINS))
|
|
-VERSION := $(shell sh mk-version)
|
|
+VERSION ?= $(shell sh mk-version)
|
|
RELEASE_VERSION := $(shell cat VERSION)
|
|
|
|
CC ?= gcc
|
|
--
|
|
2.6.4
|
|
|