kumquat-buildroot/package/libdnet/0001-python-makefile.patch
Adam Duskett ee21467863 package/libdnet: bump to version 1.14, drop python2 support.
Change the url to the github ofalk repository (SF's repo is MIA; now
everyone and their distros switched over to the Github-hosted fork).

Depend on python3 and host-python3-cython for python bindings.

Remove upstream patches; rework python-makefile.patch to adhere to
git formatting and refresh for 1.14.

Update License hash due to year changes.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
[yann.morin.1998@free.fr: rework commit log, explain switch to Github]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2022-01-01 10:46:24 +01:00

28 lines
847 B
Diff

From 298cd8eaa21a21eee85f9551a26ad294347b1d5a Mon Sep 17 00:00:00 2001
From: Peter Korsgaard <peter@korsgaard.com>
Date: Thu, 30 Dec 2021 11:14:15 -0800
Subject: [PATCH] python makefile
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
[adam: refresh for 1.14; make it git-formatted]
Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
python/Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/python/Makefile.am b/python/Makefile.am
index 1a74ef2..59fe0f3 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -11,6 +11,7 @@ $(srcdir)/dnet.c: $(srcdir)/dnet.pyx
pyrexc $(srcdir)/dnet.pyx
python-build: $(srcdir)/dnet.c
+ CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
$(PYTHON) setup.py build
touch python-build
--
2.33.1