d2afa01f76
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see:c4b53afce4
92dec548ff
and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see:409482251b
1351c31aa9
e13c3201fb
respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
897 B
Diff
31 lines
897 B
Diff
From 48f485cfdf79452308a0c6ac24a25c31bacbcbec Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:51:58 +0100
|
|
Subject: [PATCH] Add an option to disable the ossaudiodev module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 71aea1d..9a61018 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2846,6 +2846,12 @@ else
|
|
fi
|
|
AC_SUBST(MPDEC)
|
|
|
|
+AC_ARG_ENABLE(ossaudiodev,
|
|
+ AS_HELP_STRING([--disable-ossaudiodev], [disable OSSAUDIODEV]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ossaudiodev"
|
|
+ fi])
|
|
+
|
|
# Check for support for loadable sqlite extensions
|
|
AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
|
|
AC_ARG_ENABLE(loadable-sqlite-extensions,
|
|
--
|
|
2.9.3
|
|
|