kumquat-buildroot/board/andes/ae350/patches/opensbi/0001-Disable-PIC-explicitly-for-assembling.patch
Yu Chien Peter Lin fc22c3ce40 board/andes/ae350: add support for Andes AE350
This patch provides defconfig and basic support for Andes
45 series RISC-V architecture on AE350 platform.

http://www.andestech.com/en/products-solutions/andeshape-platforms/ae350-axi-based-platform-pre-integrated-with-n25f-nx25f-a25-ax25/

Signed-off-by: Yu Chien Peter Lin <peterlin@andestech.com>
Signed-off-by: Alan Kao <alankao@andestech.com>
Reviewed-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Tested-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2022-03-10 21:48:16 +01:00

30 lines
827 B
Diff

From 3ccb71eeca42dbcd5e4d00ae1877a489ae82598d Mon Sep 17 00:00:00 2001
From: Yu Chien Peter Lin <peterlin@andestech.com>
Date: Wed, 29 Dec 2021 16:04:54 +0800
Subject: [PATCH] Disable PIC explicitly for assembling
This patch is necessary if the fw_dynamic load address
is not equal to link address.
However, they are equal currently, since we include an u-boot
patch for preventing fw_dynamic relocation.
Signed-off-by: Yu Chien Peter Lin <peterlin@andestech.com>
---
Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile
index d6f097d..441518d 100644
--- a/Makefile
+++ b/Makefile
@@ -225,6 +225,7 @@ ASFLAGS += -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
ASFLAGS += $(GENFLAGS)
ASFLAGS += $(platform-asflags-y)
ASFLAGS += $(firmware-asflags-y)
+ASFLAGS += -fno-pic
ARFLAGS = rcs
--
2.25.1