kumquat-buildroot/package/tvheadend/tvheadend-no-auto-download-dvbscans.patch
Yann E. MORIN 38cdf82a76 package/dvb-apps: add option to install utilities
Previously, dvb-apps was a 'blind' package that would install
only the transponders data files for use by external packages
(namely tvheadend).

Now, we add an option to also install the DVB utilities.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
2013-01-06 21:53:47 +01:00

61 lines
2.4 KiB
Diff

Do not download transponder data as part of the build
If dvb-scan is enabled, tvheadend will download the transponders data
from the dvb-apps package. This does not play well with buildroot.
Instead, we rely on the dvb-apps package to install those files, so
it is no longer needed to install those as part of tvheadend.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -durN tvheadend-v3.3.orig//configure tvheadend-v3.3/configure
--- tvheadend-v3.3.orig//configure 2012-09-25 15:32:31.000000000 +0200
+++ tvheadend-v3.3/configure 2012-12-28 17:17:23.580253413 +0100
@@ -96,13 +96,14 @@
#
# DVB scan
#
-if enabled linuxdvb && enabled dvbscan; then
- if [ ! -d ${ROOTDIR}/data/dvb-scan ]; then
- echo -n "Fetching dvb-scan files... "
- ${ROOTDIR}/support/getmuxlist &> /dev/null || die "Failed to fetch dvb-scan files (use --disable-dvbscan to skip)"
- echo "done"
- fi
-fi
+# For buildroot, we already installed those files via the dvb-apps package
+#if enabled linuxdvb && enabled dvbscan; then
+# if [ ! -d ${ROOTDIR}/data/dvb-scan ]; then
+# echo -n "Fetching dvb-scan files... "
+# ${ROOTDIR}/support/getmuxlist &> /dev/null || die "Failed to fetch dvb-scan files (use --disable-dvbscan to skip)"
+# echo "done"
+# fi
+#fi
# ###########################################################################
# Write config
diff -durN tvheadend-v3.3.orig//Makefile tvheadend-v3.3/Makefile
--- tvheadend-v3.3.orig//Makefile 2012-09-25 15:32:31.000000000 +0200
+++ tvheadend-v3.3/Makefile 2012-12-28 17:17:47.573497346 +0100
@@ -180,7 +180,7 @@
SRCS-${CONFIG_BUNDLE} += bundle.c
BUNDLES-yes += docs/html docs/docresources src/webui/static
BUNDLES-yes += data/conf
-BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
+#BUNDLES-${CONFIG_DVBSCAN} += data/dvb-scan
BUNDLES = $(BUNDLES-yes)
#
diff -durN tvheadend-v3.3.orig//support/posix.mk tvheadend-v3.3/support/posix.mk
--- tvheadend-v3.3.orig//support/posix.mk 2012-09-25 15:32:31.000000000 +0200
+++ tvheadend-v3.3/support/posix.mk 2012-12-28 17:19:28.903121722 +0100
@@ -12,7 +12,8 @@
mkdir -p ${DESTDIR}${datadir}/tvheadend/$$bundle ;\
cp -r $$bundle/* ${DESTDIR}${datadir}/tvheadend/$$bundle ;\
done
-
+ mkdir -p ${DESTDIR}${datadir}/tvheadend/data
+ ln -sf /usr/share/dvb ${DESTDIR}${datadir}/tvheadend/data/dvb-scan
uninstall:
rm -f ${DESTDIR}${bindir)/tvheadend