1b4ee69faf
For details see [1]. Rebased patch 0001-configure-add-disable-runtime-tests-option.patch. [1] https://lists.freedesktop.org/archives/input-tools/2018-October/001488.html Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
45 lines
1.5 KiB
Diff
45 lines
1.5 KiB
Diff
From 93f6bc2b97a2b76a5e725d63d4b6c2dfe7baf63b Mon Sep 17 00:00:00 2001
|
|
From: Peter Seiderer <ps.report@gmx.net>
|
|
Date: Sun, 11 Oct 2015 13:33:19 +0200
|
|
Subject: [PATCH] configure: add '--disable-runtime-tests' option
|
|
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
[Rebased libevdev-1.6.0]
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
---
|
|
configure.ac | 11 +++++++++--
|
|
1 file changed, 9 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 5161d93..2b3bb26 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -76,7 +76,14 @@ else
|
|
AC_MSG_WARN([check not found - skipping building unit tests])
|
|
fi
|
|
AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
|
|
-AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x$HAVE_CHECK" = "xyes"])
|
|
+
|
|
+AC_ARG_ENABLE([runtime-tests],
|
|
+ AS_HELP_STRING([--disable-runtime-tests], [Disable runtime tests]))
|
|
+AS_IF([test "x$enable_runtime_tests" != "xno"],
|
|
+ [enable_runtime_tests=yes],
|
|
+ [enable_runtime_tests=no])
|
|
+
|
|
+AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x${enable_runtime_tests}x$HAVE_CHECK" = "xyesxyes"])
|
|
AM_CONDITIONAL(ENABLE_STATIC_LINK_TEST, [test "x$enable_static" = "xyes"])
|
|
|
|
with_cflags=""
|
|
@@ -162,7 +169,7 @@ AC_MSG_RESULT([
|
|
Libdir ${libdir}
|
|
|
|
Build documentation ${have_doxygen}
|
|
- Enable unit-tests ${HAVE_CHECK}
|
|
+ Enable unit-tests ${HAVE_CHECK} (runtime-tests: ${enable_runtime_tests})
|
|
Enable profiling ${enable_gcov}
|
|
Static library symbol check ${static_symbol_leaks_test}
|
|
])
|
|
--
|
|
2.19.1
|
|
|