kumquat-buildroot/package/python3/0007-Abort-on-failed-module-build.patch
Adam Duskett 0f01b69885 package/python3: bump version to 3.9.6
Other changes:
  - Rename 0034-lib-crypt-uClibc-ng-doesn-t-set-errno-when-encryptio.patch to
    0035-lib-crypt-uClibc-ng-doesn-t-set-errno-when-encryptio.patch, as to not
    overlap with 0034-Add-an-option-to-disable-the-berkeleydb-module.patch

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2021-07-04 16:17:01 +02:00

31 lines
979 B
Diff

From 188c0ebfdb71f5252fa7701013b8d1209f28aef7 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Wed, 23 Dec 2015 11:43:24 +0100
Subject: [PATCH] Abort on failed module build
When building a Python module fails, the setup.py script currently
doesn't exit with an error, and simply continues. This is not a really
nice behavior, so this patch changes setup.py to abort with an error,
so that the build issue is clearly noticeable.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
setup.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/setup.py b/setup.py
index e27620035c..d3f0e663f2 100644
--- a/setup.py
+++ b/setup.py
@@ -524,6 +524,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]
--
2.25.1