298cd8eaa2
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345) Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
Enforce correct -march option
|
|
|
|
Buildroot uses a normal ARM compiler to build the AM33X CM3 firmware
|
|
(which runs on a Cortex-M3 processor), but Buildroot will have a
|
|
default -march value that doesn't necessarily match the one needed for
|
|
Cortex-M3, leading to build failures (gcc complains that the
|
|
-mcpu=cortex-m3 option being passed is not compatible with the
|
|
selected -march).
|
|
|
|
Fix this by explicitly indicating -march=armv7-m.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Updated the patch to the latest version of the Makefile
|
|
|
|
Signed-off-by: Anders Darander <anders@chargestorm.se>
|
|
|
|
Index: b/Makefile
|
|
===================================================================
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -13,7 +13,7 @@ SRCDIR = src
|
|
BINDIR = bin
|
|
|
|
INCLUDES = $(SRCDIR)/include
|
|
-CFLAGS =-mcpu=cortex-m3 -mthumb -nostdlib -Wall -Wundef \
|
|
+CFLAGS =-march=armv7-m -mcpu=cortex-m3 -mthumb -nostdlib -Wall -Wundef \
|
|
-Werror-implicit-function-declaration -Wstrict-prototypes \
|
|
-Wdeclaration-after-statement -fno-delete-null-pointer-checks \
|
|
-Wempty-body -fno-strict-overflow -g -I$(INCLUDES) -O2
|