kumquat-buildroot/package/mupdf/0004-Makefile-compile-hexdump.exe-with-HOSTCC.patch
Fabrice Fontaine cf8900b063 package/mupdf: disable objcopy
Drop fourth patch and disable objcopy as suggested by upstream in
https://bugs.ghostscript.com/show_bug.cgi?id=704442#c2

This will also fix the following build failure on sparc and xtensa:

    OBJCOPY build/release/resources/fonts/urw/Dingbats.cff.o
/home/buildroot/autobuild/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sparc64-buildroot-linux-gnu/9.3.0/../../../../sparc64-buildroot-linux-gnu/bin/ld: --relax and -r may not be used together

While at it, drop MUPDF_DISABLE_OPENGL and use the new MUPDF_MAKE_OPTS
variable

Fixes:
 - http://autobuild.buildroot.org/results/e64d456174a0f701c0e0de68317debcdc429a660
 - http://autobuild.buildroot.net/results/0945f305d31530677282f38fa7c99af5295d47bd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2021-11-16 21:29:54 +01:00

41 lines
1.2 KiB
Diff

From c0036573a995dc78d3cf60a30ff0af2b47f3680a Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 14 Nov 2021 23:24:27 +0100
Subject: [PATCH] Makefile: compile hexdump.exe with HOSTCC
hexdump.exe must be compiled for the host or the build will fail when
cross-compiling with HAVE_OBJCOPY=no
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://bugs.ghostscript.com/show_bug.cgi?id=704442]
---
Makefile | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/Makefile b/Makefile
index 6492b1ca3..0732b358f 100644
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,8 @@ AR_CMD = $(QUIET_AR) $(MKTGTDIR) ; $(AR) cr $@ $^
ifdef RANLIB
RANLIB_CMD = $(QUIET_RANLIB) $(RANLIB) $@
endif
+HOSTCC ?= $(CC)
+HOST_LINK_CMD = $(QUIET_LINK) $(MKTGTDIR) ; $(HOSTCC) -o $@ $^
LINK_CMD = $(QUIET_LINK) $(MKTGTDIR) ; $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
TAGS_CMD = $(QUIET_TAGS) ctags -R --c-kinds=+p --exclude=platform/python --exclude=platform/c++
WINDRES_CMD = $(QUIET_WINDRES) $(MKTGTDIR) ; $(WINDRES) $< $@
@@ -81,6 +83,9 @@ $(OUT)/%.a :
$(AR_CMD)
$(RANLIB_CMD)
+$(OUT)/scripts/hexdump.exe: scripts/hexdump.c
+ $(HOST_LINK_CMD)
+
$(OUT)/%.exe: %.c
$(LINK_CMD)
--
2.33.0