80882ee661
Since glibc 2.17 the clock_* suite functions are available directly in the main C library. For previous versions we still need -lrt to link. Upstream is aware of this problem. Fixes: http://autobuild.buildroot.net/results/c11/c1182b00f9d968e587acba15af4af905b92227f5/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
19 lines
676 B
Diff
19 lines
676 B
Diff
aiccu: fix undefined reference to clock_* functions
|
|
|
|
Since glibc 2.17 the clock_* suite functions are available directly in
|
|
the main C library. For previous versions we still need -lrt to link.
|
|
|
|
Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
|
|
|
|
--- aiccu/unix-console/Makefile.orig 2014-01-14 10:17:20.204602513 +0000
|
|
+++ aiccu/unix-console/Makefile 2014-01-14 10:17:31.435777359 +0000
|
|
@@ -42,7 +42,7 @@ CFLAGS += -D AICCU_CONSOLE
|
|
# Currently defaultly builds only on Linux, but other platforms might easily also support it
|
|
ifeq ($(shell uname | grep -c "Linux"),1)
|
|
CFLAGS += -D AICCU_GNUTLS
|
|
-LDFLAGS += -lgnutls
|
|
+LDFLAGS += -lgnutls -lrt
|
|
endif
|
|
|
|
# Linux
|