aca0d2a1af
libtirpc does not implement the reentrant function getrpcbynumber_r(), so allow nfs-utils to use the non-reentrant version getrpcbynumber(). This should not be a problem as nfs-utils tools are not multi-threaded. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
From 7ea7814a8b87a0faa50fb9f4a486bfd7a376f3fc Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Sat, 10 Nov 2012 18:53:03 +0100
|
|
Subject: [PATCH] Let the configure script find getrpcbynumber in libtirpc
|
|
|
|
The getrpcbynumber() function may not be available in the C library,
|
|
but only in the libtirpc library. Take this into account when checking
|
|
for the existence of getrpcbynumber() and getrpcbynumber_r().
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 10 +++++++++-
|
|
1 file changed, 9 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 41216c9..1bbecfa 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -390,7 +390,15 @@ AC_CHECK_FUNCS([alarm atexit dup2 fdatasync ftruncate getcwd \
|
|
getnameinfo getrpcbyname getifaddrs \
|
|
gettimeofday hasmntopt inet_ntoa innetgr memset mkdir pathconf \
|
|
realpath rmdir select socket strcasecmp strchr strdup \
|
|
- strerror strrchr strtol strtoul sigprocmask getrpcbynumber getrpcbynumber_r])
|
|
+ strerror strrchr strtol strtoul sigprocmask])
|
|
+
|
|
+save_CFLAGS=$CFLAGS
|
|
+save_LIBS=$LIBS
|
|
+CFLAGS="$CFLAGS $AM_CPPFLAGS"
|
|
+LIBS="$LIBS $LIBTIRPC"
|
|
+AC_CHECK_FUNCS([getrpcbynumber getrpcbynumber_r])
|
|
+CFLAGS=$save_CFLAGS
|
|
+LIBS=$save_LIBS
|
|
|
|
if test "$ac_cv_func_getrpcbynumber_r" != "yes" -a "$ac_cv_func_getrpcbynumber" != "yes"; then
|
|
AC_MSG_ERROR([Neither getrpcbynumber_r nor getrpcbynumber are available])
|
|
--
|
|
1.7.9.5
|
|
|