kumquat-buildroot/package/libepoxy/0002-add-an-option-to-disable-glx-support.patch
Gustavo Zacarias 0911f32d1c libepoxy: move outside x11r7 scope
Move it outside x11r7 scope since it can be built without it with a few
patches (sent upstream via github pull request).

Motivation is simple, it's a dependency for newer gtk3 versions which
can work with a wayland or broadway backend, and having a full x11 stack
is pointless for that scenario.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: split the first patch into four separate patches, since
that's how they were submitted upstream.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-03-20 18:34:10 +01:00

40 lines
1.3 KiB
Diff

From a9efde0fb2678cd26bdf26d256732d97ded0c595 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
Date: Wed, 6 May 2015 11:05:48 +0200
Subject: [PATCH 2/4] add an option to disable glx support
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
this option would help us in yocto to get deterministic build results
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Fetched from pull #81 on github for libepoxy:
https://github.com/anholt/libepoxy/pull/81/commits
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
configure.ac | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 225ab73..d3d947c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,14 @@ AC_CHECK_HEADER([KHR/khrplatform.h],
# uintptr_t to a void *") by default. Kill that.
XORG_TESTSET_CFLAG(CWARNFLAGS, [-Wno-int-conversion])
-PKG_CHECK_MODULES(X11, [x11], [x11=yes], [x11=no])
+AC_ARG_ENABLE([glx],
+ [AS_HELP_STRING([--disable-glx],
+ [disable if you don't want x11/glx support])],
+ [],
+ [enable_glx=yes]
+ )
+
+PKG_CHECK_MODULES(X11, [x11], [x11=$enable_glx], [x11=no])
AM_CONDITIONAL(HAVE_X11, test x$x11 = xyes)