cb328f77f8
This package contains the core policy utilities that are required for basic operation of an SELinux system. Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com> Tested-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com> Signed-off-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com> [Thomas: - Move the Config.in comment at the top of the Config.in file rather than between the main option and its sub-options, as this breaks menuconfig indentation. - Fix the propagation of the libsemanage dependencies. libsemanage depends on BR2_PACKAGE_AUDIT_ARCH_SUPPORTS and BR2_TOOLCHAIN_USES_GLIBC which were not accounted for. Since it depends on BR2_TOOLCHAIN_USES_GLIBC, then all the gettext related handling becomes useless and has been removed. - Rename the prompt of the restorecond sub-option to just "restorecond". - Use TARGET_CONFIGURE_OPTS and HOST_CONFIGURE_OPTS instead of passing LDFLAGS, CC, etc. manually. - Use make "foreach" function for loops instead of shell "for" loops. - Rework the explanation of why we're passing DESTDIR at build time. - Minor formatting tweaks here and there.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
44 lines
1.3 KiB
Diff
44 lines
1.3 KiB
Diff
From 7424f2bea0cb412e96202f596ad8077131589f40 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Aduskett@gmail.com>
|
|
Date: Thu, 14 Jul 2016 13:18:24 -0400
|
|
Subject: [PATCH] Remove hardcoded arch variable.
|
|
|
|
Allow the ARCH value to be passed in as original configuration was
|
|
solely based on host architecture.
|
|
|
|
This patch was updated to work with version 2.5
|
|
|
|
Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
|
|
Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com>
|
|
Signed-off-by: Adam Duskett <AdamDuskett@outlook.com>
|
|
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
|
|
---
|
|
policycoreutils/mcstrans/src/Makefile | 1 -
|
|
policycoreutils/mcstrans/utils/Makefile | 1 -
|
|
2 files changed, 2 deletions(-)
|
|
|
|
diff --git a/mcstrans/src/Makefile b/mcstrans/src/Makefile
|
|
index 6fda57e..7b4489f 100644
|
|
--- a/mcstrans/src/Makefile
|
|
+++ b/mcstrans/src/Makefile
|
|
@@ -1,4 +1,3 @@
|
|
-ARCH = $(shell uname -i)
|
|
# Installation directories.
|
|
PREFIX ?= $(DESTDIR)/usr
|
|
SBINDIR ?= $(DESTDIR)/sbin
|
|
diff --git a/mcstrans/utils/Makefile b/mcstrans/utils/Makefile
|
|
index 1ffb027..912fe12 100644
|
|
--- a/mcstrans/utils/Makefile
|
|
+++ b/mcstrans/utils/Makefile
|
|
@@ -2,7 +2,6 @@
|
|
PREFIX ?= $(DESTDIR)/usr
|
|
BINDIR ?= $(PREFIX)/sbin
|
|
|
|
-ARCH = $(shell uname -i)
|
|
ifeq "$(ARCH)" "x86_64"
|
|
# In case of 64 bit system, use these lines
|
|
LIBDIR=/usr/lib64
|
|
--
|
|
2.7.4
|
|
|