c05cc5de86
madplay uses a very old configure script. When the toolchain lacks C++ and the build machine lacks /lib/cpp, this old configure script fails because it can't find a C++ preprocessor that is valid: checking for arm-buildroot-linux-uclibcgnueabi-g++... no checking whether we are using the GNU C++ compiler... no checking whether no accepts -g... no checking dependency style of no... none checking how to run the C++ preprocessor... /lib/cpp configure: error: C++ preprocessor "/lib/cpp" fails sanity check See `config.log' for more details. This is yet another case that was tentatively fixed bybd39d11d2e
(core/infra: fix build on toolchain without C++), further amended by4cd1ab1588
(core: alternate solution to disable C++). However, this only works on libtool scripts that are recent enough, and thus we need to autoreconf to get it. We also need to patch configure.ac so that it does not fail on the missing, GNU-specific files: NEWS, AUTHORS, and Changelog. Finally, remove also patch on ltmain.sh and MADPLAY_LIBTOOL_PATCH=NO as autoreconf will create an up to date ltmain.sh Fixes: - http://autobuild.buildroot.org/results/fc927de0e9a42095789fb0a631d5facf14076f6e Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
17 lines
483 B
Diff
17 lines
483 B
Diff
configure.ac: don't require GNU-specific files when running automake
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
|
|
diff -durN madplay-0.15.2b-orig/configure.ac madplay-0.15.2b/configure.ac
|
|
--- madplay-0.15.2b-orig/configure.ac 2019-02-14 21:34:01.507212449 +0100
|
|
+++ madplay-0.15.2b/configure.ac 2019-02-14 21:34:23.439336353 +0100
|
|
@@ -26,7 +26,7 @@
|
|
|
|
AC_CONFIG_SRCDIR([madplay.c])
|
|
|
|
-AM_INIT_AUTOMAKE
|
|
+AM_INIT_AUTOMAKE([foreign])
|
|
|
|
AM_CONFIG_HEADER([config.h])
|
|
|