f41ae56c65
Add introspection support to harfbuzz otherwise activation of introspection in pango 1.46.1 will fail on: Couldn't find include 'HarfBuzz-0.0.gir' (search path: '['/home/naourr/work/instance-2/output-1/host/aarch64-buildroot-linux-gnu/sysroot/usr/bin/../share/gir-1.0', '/home/naourr/work/instance-2/output-1/host/share/gir-1.0', '/home/naourr/work/instance-2/output-1/host/share', '/home/naourr/.local/share/flatpak/exports/share/gir-1.0', '/var/lib/flatpak/exports/share/gir-1.0', '/usr/local/share/gir-1.0', '/usr/share/gir-1.0', '/home/naourr/work/instance-2/output-1/host/share/gir-1.0', '/usr/share/gir-1.0']') Fixes: - http://autobuild.buildroot.org/results/3357225ee2d8392bfd57af91cde04a1113e03493 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 432dfd0a1d8fe0a8df89e7ce828c520c7758f10c Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Thu, 24 Sep 2020 21:00:34 +0200
|
|
Subject: [PATCH] src/meson.build: allow introspection when cross-compiling
|
|
|
|
introspection can be enabled when cross-compiling on certains conditions
|
|
(for example it is supported by buildroot)
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/harfbuzz/harfbuzz/pull/2692]
|
|
---
|
|
src/meson.build | 5 -----
|
|
1 file changed, 5 deletions(-)
|
|
|
|
diff --git a/src/meson.build b/src/meson.build
|
|
index 19290245..7db43508 100644
|
|
--- a/src/meson.build
|
|
+++ b/src/meson.build
|
|
@@ -637,11 +637,6 @@ if have_gobject
|
|
gir = find_program('g-ir-scanner', required: get_option('introspection'))
|
|
build_gir = gir.found()
|
|
|
|
- build_gir = build_gir and not meson.is_cross_build()
|
|
- if not build_gir and get_option('introspection').enabled()
|
|
- error('Introspection support is requested but it isn\'t available in cross builds')
|
|
- endif
|
|
-
|
|
build_gir = build_gir and get_option('default_library') != 'static'
|
|
if not build_gir and get_option('introspection').enabled()
|
|
error('Introspection support is requested but the default library option should be shared or both')
|
|
--
|
|
2.28.0
|
|
|