28d8bfecba
Sorry, my repos got mixed up, so I forgot to send the updated patches. Fixes http://autobuild.buildroot.net/results/ddd/ddd196577643de5b4f58a0903b19a04513620693/ http://autobuild.buildroot.net/results/d25/d253c8c9d0773843c462fde0d5005bb14e4ce2c4/ http://autobuild.buildroot.net/results/b61/b61d582c7362332e0ffad645c90d95d880dacedc/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
17 lines
803 B
Diff
17 lines
803 B
Diff
tvheadend: remove -Werror from CFLAGS
|
|
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
|
|
diff -durN tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/Makefile tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/Makefile
|
|
--- tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3.orig/Makefile 2014-03-09 14:50:48.437688482 +0100
|
|
+++ tvheadend-c84bc2b72b462ef2dbed305f3fd0bb3fa5046fc3/Makefile 2014-03-09 14:54:00.411418749 +0100
|
|
@@ -32,7 +32,7 @@
|
|
ifeq ($(CONFIG_W_UNUSED_RESULT),yes)
|
|
CFLAGS += -Wunused-result
|
|
endif
|
|
-CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
|
|
+CFLAGS += -Wall -Wwrite-strings -Wno-deprecated-declarations
|
|
CFLAGS += -Wmissing-prototypes
|
|
CFLAGS += -fms-extensions -funsigned-char -fno-strict-aliasing
|
|
CFLAGS += -D_FILE_OFFSET_BITS=64
|