46aab84c6f
This will fix the following build failure with python 3.9 and sigrok-cli: /srv/storage/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips64el-buildroot-linux-uclibc/5.5.0/../../../../mips64el-buildroot-linux-uclibc/bin/ld: /srv/storage/autobuild/run/instance-1/output-1/host/bin/../mips64el-buildroot-linux-uclibc/sysroot/usr/lib/libsigrokdecode.so: undefined reference to `PyList_Insert' Fixes: - http://autobuild.buildroot.org/results/cc6447b926f8223c68d0086428d29a037b18252d Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
1.3 KiB
Diff
29 lines
1.3 KiB
Diff
From 9b0ad5177bd692f7556a4756bdbd2da81d9c34ce Mon Sep 17 00:00:00 2001
|
|
From: =?utf8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
|
Date: Tue, 4 Aug 2020 09:19:44 +0200
|
|
Subject: [PATCH] configure.ac: Add support for Python 3.9.
|
|
|
|
[Retrieved from:
|
|
https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commit;h=9b0ad5177bd692f7556a4756bdbd2da81d9c34ce]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index f9958b3..2917cb3 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
|
|
# first, since usually only that variant will add "-lpython3.8".
|
|
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
|
|
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
|
|
- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
+ [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
AS_IF([test "x$sr_have_python3" = xno],
|
|
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])
|
|
|
|
--
|
|
2.24.0.rc2
|
|
|