50368ac2ab
Patches downloaded from Github are not stable, so bring them in the tree. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
From 27916ce3db023454a0295ee63ea196fbc246674c Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 6 Sep 2016 22:19:14 +0200
|
|
Subject: [PATCH] Build NEON code with -mfpu=neon
|
|
|
|
The ARM-specific NEON code needs to be built with -mfpu=neon to avoid
|
|
build failures when a difference FPU is used by default by the
|
|
compiler.
|
|
|
|
Fixes issue #54.
|
|
|
|
[Upstream commit: https://github.com/kcat/openal-soft/commit/27916ce3db023454a0295ee63ea196fbc246674c]
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
CMakeLists.txt | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index d8f15153..d92bbb7d 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -767,6 +767,7 @@ IF(HAVE_ARM_NEON_H)
|
|
SET(HAVE_NEON 1)
|
|
SET(ALC_OBJS ${ALC_OBJS} Alc/mixer_neon.c)
|
|
SET(CPU_EXTS "${CPU_EXTS}, Neon")
|
|
+ SET_SOURCE_FILES_PROPERTIES(Alc/mixer_neon.c PROPERTIES COMPILE_FLAGS -mfpu=neon)
|
|
ENDIF()
|
|
ENDIF()
|
|
IF(ALSOFT_REQUIRE_NEON AND NOT HAVE_NEON)
|