c970d7d640
Fixes the following security issues: - CVE-2013-1752: Change use of readline() in :class:`imaplib.IMAP4_SSL` to limit line length - CVE-2018-14647: The C accelerated _elementtree module now initializes hash randomization salt from _Py_HashSecret instead of libexpat's default CSPRNG. For more details, see the NEWS file: https://github.com/python/cpython/blob/v2.7.16/Misc/NEWS.d/2.7.16rc1.rst Refresh patches, drop now upstream package/python/0035-bpo-35746-Fix-segfault-in-ssl-s-cert-parser-GH-11569.patch and adjust hash of LICENSE file for a change of copyright years. run-tests results: 16:05:41 TestPython2 Starting 16:05:42 TestPython2 Building 16:11:26 TestPython2 Building done 16:11:32 TestPython2 Cleaning up . ---------------------------------------------------------------------- Ran 1 test in 351.905s OK Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
44 lines
1.7 KiB
Diff
44 lines
1.7 KiB
Diff
From 706d62599fb3c3cb9b9941364aaf4a1ef4ebd276 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Tue, 7 Mar 2017 22:23:58 +0100
|
|
Subject: [PATCH] Remove the python symlink install rules
|
|
|
|
The python symlink installation will be handled by Buildroot itself,
|
|
because Buildroot needs to control to what python interpreter (python2
|
|
or python3) the python symlink points to.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
[Bernd: rebased against version 2.7.12.]
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
[Peter: update for 2.7.16]
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
---
|
|
Makefile.pre.in | 7 -------
|
|
1 file changed, 7 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index 727a92af42..37b2ff3a5f 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -978,17 +978,10 @@ bininstall: altbininstall
|
|
echo "Creating directory $(LIBPC)"; \
|
|
$(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC); \
|
|
fi
|
|
- -if test -f $(DESTDIR)$(BINDIR)/$(PYTHON) -o -h $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- else true; \
|
|
- fi
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2$(EXE) $(PYTHON))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2$(EXE)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python2$(EXE))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2-config
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python2-config)
|
|
- -rm -f $(DESTDIR)$(BINDIR)/python-config
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2-config python-config)
|
|
-test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)
|
|
-rm -f $(DESTDIR)$(LIBPC)/python2.pc
|
|
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python2.pc)
|
|
--
|
|
2.11.0
|
|
|