52c5c6050c
Refreshed patch #1 and disable debuginfod. The debuginfod tools needs to hook into serverinfrastructure, this currently only exists for Fedora. Signed-off-by: Norbert Lange <nolange79@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
64 lines
2.0 KiB
Diff
64 lines
2.0 KiB
Diff
From dfea82b761b2ea4708fbf9370a5467ae4be525ca Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Mon, 29 May 2017 23:03:48 +0300
|
|
Subject: [PATCH] Add a --{enable,disable}-progs configure option
|
|
|
|
Add a --{enable,disable}-progs configuration option to elfutils. This
|
|
allows to selectively disable the compilation of the elfutils programs
|
|
(in which case only the libraries are built and installed). This is
|
|
useful because the programs are often not needed, and also because
|
|
building the programs against uClibc causes several issues (lack of
|
|
obstack_printf() in uClibc for example).
|
|
|
|
Based on the former patch by Thomas Petazzoni.
|
|
|
|
[Vincent: tweak patch for 0.166]
|
|
[Bernd: rebased patch for 0.177]
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
Makefile.am | 6 +++++-
|
|
configure.ac | 6 ++++++
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 2ff444e7bf1d..70443abb4fb6 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -26,8 +26,12 @@ AM_MAKEFLAGS = --no-print-directory
|
|
|
|
pkginclude_HEADERS = version.h
|
|
|
|
+if ENABLE_PROGS
|
|
+PROGS_SUBDIR = src
|
|
+endif
|
|
+
|
|
SUBDIRS = config m4 lib libelf libcpu backends libebl libdwelf libdwfl libdw \
|
|
- libasm debuginfod src po doc tests
|
|
+ libasm debuginfod $(PROGS_SUBDIR) po doc tests
|
|
|
|
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
|
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c2c1d90b2133..7b4c38381cca 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -390,6 +390,12 @@
|
|
[tests_use_rpath=$enableval], [tests_use_rpath=no])
|
|
AM_CONDITIONAL(TESTS_RPATH, test "$tests_use_rpath" = yes)
|
|
|
|
+AC_ARG_ENABLE([progs],
|
|
+ AS_HELP_STRING([--enable-progs], [enable progs]),
|
|
+ enable_progs=$enableval,
|
|
+ enable_progs=yes)
|
|
+AM_CONDITIONAL(ENABLE_PROGS, test "$enable_progs" = yes)
|
|
+
|
|
dnl zlib is mandatory.
|
|
save_LIBS="$LIBS"
|
|
LIBS=
|
|
--
|
|
2.11.0
|
|
|