4246d50559
- Renumber patch - Update hash of README.md (changes not related to license) - FPIN support is fixed by setting LINUX_HEADERS_INCDIR and63aa47d032
FPIN support is (wrongly) enabled if ELS_DTAG_LNK_INTEGRITY is defined in /usr/include/scsi/fc/fc_els.h since bump to version 0.8.9 in commitb790ff27d5
andcfff03efbc
resulting in the following build failure: In file included from /nvmedata/autobuild/instance-7/output-1/host/nios2-buildroot-linux-gnu/sysroot/usr/include/scsi/scsi_netlink_fc.h:25, from fpin_handlers.c:6: /nvmedata/autobuild/instance-7/output-1/host/nios2-buildroot-linux-gnu/sysroot/usr/include/scsi/scsi_netlink.h:44:2: error: unknown type name 'uint8_t' 44 | uint8_t version; | ^~~~~~~ https://github.com/opensvc/multipath-tools/compare/0.8.9...0.9.0 Fixes: - http://autobuild.buildroot.org/results/32f4ada6c49261924ca78f62dee43241bda379a3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
878 B
Diff
36 lines
878 B
Diff
From 8370da992c752e4238de7a8b02ce0e179353c959 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Egorenkov <egorenar-dev@posteo.net>
|
|
Date: Sun, 6 Sep 2020 10:37:41 +0200
|
|
Subject: [PATCH] Makefile.inc: Enable systemd if ENABLE_SYSTEMD is defined
|
|
|
|
systemd is disabled by default, to activate it set ENABLE_SYSTEMD.
|
|
|
|
Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net>
|
|
---
|
|
Makefile.inc | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/Makefile.inc b/Makefile.inc
|
|
index d4d1e0dd..32bc1846 100644
|
|
--- a/Makefile.inc
|
|
+++ b/Makefile.inc
|
|
@@ -35,6 +35,7 @@ ifndef RUN
|
|
endif
|
|
endif
|
|
|
|
+ifdef ENABLE_SYSTEMD
|
|
ifndef SYSTEMD
|
|
ifeq ($(shell pkg-config --modversion libsystemd >/dev/null 2>&1 && echo 1), 1)
|
|
SYSTEMD = $(shell pkg-config --modversion libsystemd)
|
|
@@ -45,6 +46,7 @@ ifndef SYSTEMD
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
|
|
ifndef SYSTEMDPATH
|
|
SYSTEMDPATH=usr/lib
|
|
--
|
|
2.28.0
|
|
|