6e6e8d37b5
Bump Python3 version to 3.6.2. Patches dropped: "Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD" Rationale: With commit 9d02f562961efd12d3c8317a10916db7f77330cc, code generation step of building CPython now became explicit (instead of always performed as a part of 'make' invocation) and more granular. We no longer need to use Parser/pgen at all and tricking the build system into using different Programs/_freeze_importlib can be done as a part of recipe. Additional info about the build change can be found at https://bugs.python.org/issue23404 Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
895 B
Diff
31 lines
895 B
Diff
From d35deaa5c65c29f2a56a29fd5fc1dadadd485eaf Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 23:29:05 +0100
|
|
Subject: [PATCH] Add an option to disable the readline module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 28bcdabd67..484f6ebaca 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3166,6 +3166,12 @@ AC_ARG_ENABLE(openssl,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(readline,
|
|
+ AS_HELP_STRING([--disable-readline], [disable readline]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.13.5
|
|
|