cccc5a2627
Make sure the build doesn't use keysymdef.h from the host.
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
[patch]: configure: add --with-keysymdef argument for cross compilation
|
|
|
|
Based on a similar patch from Openembedded.
|
|
|
|
The libX11 configure script hardcodes the location to keysymdef.h as
|
|
<prefix>/include/X11/keysymdef.h, which is fine for native compilation,
|
|
but breaks with cross compilation as that directory is a location on
|
|
the target, not the build host.
|
|
|
|
Fix it by providing an explicit --with-keysymdef=<full-path-to-file>.
|
|
|
|
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>Index: libX11-1.1.5/configure.ac
|
|
===================================================================
|
|
--- libX11-1.1.5.orig/configure.ac 2008-10-28 11:36:49.000000000 +0000
|
|
+++ libX11-1.1.5/configure.ac 2008-10-28 11:40:05.000000000 +0000
|
|
@@ -221,13 +221,21 @@
|
|
# Find keysymdef.h
|
|
#
|
|
AC_MSG_CHECKING([keysymdef.h])
|
|
-dir=`pkg-config --variable=includedir xproto`
|
|
-KEYSYMDEF="$dir/X11/keysymdef.h"
|
|
+AC_ARG_WITH(keysymdef,
|
|
+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
|
|
+ KEYSYMDEF=$withval, KEYSYMDEF="")
|
|
+
|
|
+if test x$KEYSYMDEF = x; then
|
|
+ dir=`pkg-config --variable=includedir xproto`
|
|
+ KEYSYMDEF="$dir/X11/keysymdef.h"
|
|
+fi
|
|
+
|
|
if test -f "$KEYSYMDEF"; then
|
|
- AC_MSG_RESULT([$KEYSYMDEF])
|
|
+ AC_MSG_RESULT([$KEYSYMDEF])
|
|
else
|
|
AC_MSG_ERROR([Cannot find keysymdef.h])
|
|
fi
|
|
+
|
|
AC_SUBST(KEYSYMDEF)
|
|
|
|
AM_CONDITIONAL(UDC, test xfalse = xtrue)
|