8bdb7bd3aa
pointers. Fix it by using socklen_t type. - Modify acpid.mk to apply all available patches. Convert ACPI_SOCKETFILE adjustment from sed script to a patch. Thanks to Pavel Roskin
12 lines
358 B
Diff
12 lines
358 B
Diff
--- acpid-1.0.4/ud_socket.c
|
|
+++ acpid-1.0.4/ud_socket.c
|
|
@@ -58,7 +58,7 @@ ud_accept(int listenfd, struct ucred *cr
|
|
while (1) {
|
|
int newsock = 0;
|
|
struct sockaddr_un cliaddr;
|
|
- int len = sizeof(struct sockaddr_un);
|
|
+ socklen_t len = sizeof(struct sockaddr_un);
|
|
|
|
newsock = accept(listenfd, (struct sockaddr *)&cliaddr, &len);
|
|
if (newsock < 0) {
|