a2cc96556e
Now that we are always explicitly passing gcc_cv_libc_provides_ssp, there is no longer any reason to modify the gcc configure/configure.ac to take into account the musl case. When a musl toolchain is being built, BR2_TOOLCHAIN_HAS_SSP is always 'y', and therefore gcc_cv_libc_provides_ssp=yes is always passed when building gcc-initial and gcc-final. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
588 lines
20 KiB
Diff
588 lines
20 KiB
Diff
Add musl support to gcc
|
|
|
|
This patch comes from the musl-cross project at
|
|
https://bitbucket.org/GregorR/musl-cross/src. Compared to the upstream version:
|
|
|
|
* the config.sub modifications have been removed, because Buildroot
|
|
already overwrites all config.sub with a more recent config.sub
|
|
that has musl support.
|
|
|
|
* change to ensure that a dummy dynamic linker path
|
|
MUSL_DYNAMIC_LINKER<foo> is defined for all architectures,
|
|
otherwise building gcc for architectures not supported by musl was
|
|
causing build failure. Bug reported upstream at
|
|
https://bitbucket.org/GregorR/musl-gcc-patches/issue/4/musl-gcc-patches-break-the-build-on.
|
|
|
|
* change the USE_PT_GNU_EH_FRAME logic to keep the existing gcc logic
|
|
and only add the musl one as an addition, not as a replacement. Not
|
|
doing this breaks C++ exception handling with glibc, because
|
|
USE_PT_GNU_EH_FRAME doesn't get defined due to the configure script
|
|
not testing dl_iterate_phdr() on any system except Solaris.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
|
|
# HG changeset patch
|
|
# Parent f50bb54f331f73405131a30b4f353cfda1c70304
|
|
Use the generic implementation of libstdc++ primitives when we're on musl, not the glibc one.
|
|
|
|
Index: b/libstdc++-v3/configure.host
|
|
===================================================================
|
|
--- a/libstdc++-v3/configure.host
|
|
+++ b/libstdc++-v3/configure.host
|
|
@@ -243,6 +243,13 @@
|
|
os_include_dir="os/bsd/freebsd"
|
|
;;
|
|
gnu* | linux* | kfreebsd*-gnu | knetbsd*-gnu)
|
|
+ # check for musl by target
|
|
+ case "${host_os}" in
|
|
+ *-musl*)
|
|
+ os_include_dir="os/generic"
|
|
+ ;;
|
|
+ *)
|
|
+
|
|
if [ "$uclibc" = "yes" ]; then
|
|
os_include_dir="os/uclibc"
|
|
elif [ "$bionic" = "yes" ]; then
|
|
@@ -251,6 +258,9 @@
|
|
os_include_dir="os/gnu-linux"
|
|
fi
|
|
;;
|
|
+
|
|
+ esac
|
|
+ ;;
|
|
hpux*)
|
|
os_include_dir="os/hpux"
|
|
;;
|
|
Index: b/gcc/config.gcc
|
|
===================================================================
|
|
--- a/gcc/config.gcc
|
|
+++ b/gcc/config.gcc
|
|
@@ -522,7 +522,7 @@
|
|
esac
|
|
|
|
# Common C libraries.
|
|
-tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3"
|
|
+tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3 LIBC_MUSL=4"
|
|
|
|
# Common parts for widely ported systems.
|
|
case ${target} in
|
|
@@ -625,6 +625,9 @@
|
|
*-*-*uclibc*)
|
|
tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
|
|
;;
|
|
+ *-*-*musl*)
|
|
+ tm_defines="$tm_defines DEFAULT_LIBC=LIBC_MUSL"
|
|
+ ;;
|
|
*)
|
|
tm_defines="$tm_defines DEFAULT_LIBC=LIBC_GLIBC"
|
|
;;
|
|
@@ -2091,6 +2094,10 @@
|
|
powerpc*-*-linux*paired*)
|
|
tm_file="${tm_file} rs6000/750cl.h" ;;
|
|
esac
|
|
+ case ${target} in
|
|
+ *-linux*-musl*)
|
|
+ enable_secureplt=yes ;;
|
|
+ esac
|
|
if test x${enable_secureplt} = xyes; then
|
|
tm_file="rs6000/secureplt.h ${tm_file}"
|
|
fi
|
|
Index: b/gcc/config/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/linux.h
|
|
+++ b/gcc/config/linux.h
|
|
@@ -33,10 +33,12 @@
|
|
#define OPTION_GLIBC (DEFAULT_LIBC == LIBC_GLIBC)
|
|
#define OPTION_UCLIBC (DEFAULT_LIBC == LIBC_UCLIBC)
|
|
#define OPTION_BIONIC (DEFAULT_LIBC == LIBC_BIONIC)
|
|
+#define OPTION_MUSL (DEFAULT_LIBC == LIBC_MUSL)
|
|
#else
|
|
#define OPTION_GLIBC (linux_libc == LIBC_GLIBC)
|
|
#define OPTION_UCLIBC (linux_libc == LIBC_UCLIBC)
|
|
#define OPTION_BIONIC (linux_libc == LIBC_BIONIC)
|
|
+#define OPTION_MUSL (linux_libc == LIBC_MUSL)
|
|
#endif
|
|
|
|
#define GNU_USER_TARGET_OS_CPP_BUILTINS() \
|
|
@@ -54,18 +56,21 @@
|
|
uClibc or Bionic is the default C library and whether
|
|
-muclibc or -mglibc or -mbionic has been passed to change the default. */
|
|
|
|
-#define CHOOSE_DYNAMIC_LINKER1(LIBC1, LIBC2, LIBC3, LD1, LD2, LD3) \
|
|
- "%{" LIBC2 ":" LD2 ";:%{" LIBC3 ":" LD3 ";:" LD1 "}}"
|
|
+#define CHOOSE_DYNAMIC_LINKER1(LIBC1, LIBC2, LIBC3, LIBC4, LD1, LD2, LD3, LD4) \
|
|
+ "%{" LIBC2 ":" LD2 ";:%{" LIBC3 ":" LD3 ";:%{" LIBC4 ":" LD4 ";:" LD1 "}}}"
|
|
|
|
#if DEFAULT_LIBC == LIBC_GLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("mglibc", "muclibc", "mbionic", G, U, B)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mglibc", "muclibc", "mbionic", "mmusl", G, U, B, M)
|
|
#elif DEFAULT_LIBC == LIBC_UCLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("muclibc", "mglibc", "mbionic", U, G, B)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("muclibc", "mglibc", "mbionic", "mmusl", U, G, B, M)
|
|
#elif DEFAULT_LIBC == LIBC_BIONIC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U, B) \
|
|
- CHOOSE_DYNAMIC_LINKER1 ("mbionic", "mglibc", "muclibc", B, G, U)
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mbionic", "mglibc", "muclibc", "mmusl", B, G, U, M)
|
|
+#elif DEFAULT_LIBC == LIBC_MUSL
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, B, M) \
|
|
+ CHOOSE_DYNAMIC_LINKER1 ("mmusl", "mglibc", "muclibc", "mbionic", M, G, U, B)
|
|
#else
|
|
#error "Unsupported DEFAULT_LIBC"
|
|
#endif /* DEFAULT_LIBC */
|
|
@@ -83,23 +88,32 @@
|
|
#define BIONIC_DYNAMIC_LINKER64 "/system/bin/linker64"
|
|
#define BIONIC_DYNAMIC_LINKERX32 "/system/bin/linkerx32"
|
|
|
|
+/* Musl dynamic linker paths must be defined on a per-architecture
|
|
+ basis, for each architecture supported by Musl. However, in order
|
|
+ to let other architectures continue to build with other C
|
|
+ libraries, we provide a dummy definition of the following defines. */
|
|
+#define MUSL_DYNAMIC_LINKER "invalid"
|
|
+#define MUSL_DYNAMIC_LINKER32 "invalid"
|
|
+#define MUSL_DYNAMIC_LINKER64 "invalid"
|
|
+#define MUSL_DYNAMIC_LINKERX32 "invalid"
|
|
+
|
|
#define GNU_USER_DYNAMIC_LINKER \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER, \
|
|
- BIONIC_DYNAMIC_LINKER)
|
|
+ BIONIC_DYNAMIC_LINKER, MUSL_DYNAMIC_LINKER)
|
|
#define GNU_USER_DYNAMIC_LINKER32 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER32, UCLIBC_DYNAMIC_LINKER32, \
|
|
- BIONIC_DYNAMIC_LINKER32)
|
|
+ BIONIC_DYNAMIC_LINKER32, MUSL_DYNAMIC_LINKER32)
|
|
#define GNU_USER_DYNAMIC_LINKER64 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64, \
|
|
- BIONIC_DYNAMIC_LINKER64)
|
|
+ BIONIC_DYNAMIC_LINKER64, MUSL_DYNAMIC_LINKER64)
|
|
#define GNU_USER_DYNAMIC_LINKERX32 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKERX32, UCLIBC_DYNAMIC_LINKERX32, \
|
|
- BIONIC_DYNAMIC_LINKERX32)
|
|
+ BIONIC_DYNAMIC_LINKERX32, MUSL_DYNAMIC_LINKERX32)
|
|
|
|
/* Determine whether the entire c99 runtime
|
|
is present in the runtime library. */
|
|
#undef TARGET_C99_FUNCTIONS
|
|
-#define TARGET_C99_FUNCTIONS (OPTION_GLIBC)
|
|
+#define TARGET_C99_FUNCTIONS (OPTION_GLIBC || OPTION_MUSL)
|
|
|
|
/* Whether we have sincos that follows the GNU extension. */
|
|
#undef TARGET_HAS_SINCOS
|
|
@@ -108,3 +122,74 @@
|
|
/* Whether we have Bionic libc runtime */
|
|
#undef TARGET_HAS_BIONIC
|
|
#define TARGET_HAS_BIONIC (OPTION_BIONIC)
|
|
+
|
|
+/* musl avoids problematic includes by rearranging the include directories.
|
|
+ * Unfortunately, this is mostly duplicated from cppdefault.c */
|
|
+#if DEFAULT_LIBC == LIBC_MUSL
|
|
+#define INCLUDE_DEFAULTS_MUSL_GPP \
|
|
+ { GPLUSPLUS_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 0 }, \
|
|
+ { GPLUSPLUS_TOOL_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 1 }, \
|
|
+ { GPLUSPLUS_BACKWARD_INCLUDE_DIR, "G++", 1, 1, \
|
|
+ GPLUSPLUS_INCLUDE_DIR_ADD_SYSROOT, 0 },
|
|
+
|
|
+#ifdef LOCAL_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_LOCAL \
|
|
+ { LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 2 }, \
|
|
+ { LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 0 },
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+#endif
|
|
+
|
|
+#ifdef PREFIX_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_PREFIX \
|
|
+ { PREFIX_INCLUDE_DIR, 0, 0, 1, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_PREFIX
|
|
+#endif
|
|
+
|
|
+#ifdef CROSS_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_CROSS \
|
|
+ { CROSS_INCLUDE_DIR, "GCC", 0, 0, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+#endif
|
|
+
|
|
+#ifdef TOOL_INCLUDE_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_TOOL \
|
|
+ { TOOL_INCLUDE_DIR, "BINUTILS", 0, 1, 0, 0},
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_TOOL
|
|
+#endif
|
|
+
|
|
+#ifdef NATIVE_SYSTEM_HEADER_DIR
|
|
+#define INCLUDE_DEFAULTS_MUSL_NATIVE \
|
|
+ { NATIVE_SYSTEM_HEADER_DIR, 0, 0, 0, 1, 2 }, \
|
|
+ { NATIVE_SYSTEM_HEADER_DIR, 0, 0, 0, 1, 0 },
|
|
+#else
|
|
+#define INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+#endif
|
|
+
|
|
+#if defined (CROSS_DIRECTORY_STRUCTURE) && !defined (TARGET_SYSTEM_ROOT)
|
|
+# undef INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+# define INCLUDE_DEFAULTS_MUSL_LOCAL
|
|
+# undef INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+# define INCLUDE_DEFAULTS_MUSL_NATIVE
|
|
+#else
|
|
+# undef INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+# define INCLUDE_DEFAULTS_MUSL_CROSS
|
|
+#endif
|
|
+
|
|
+#undef INCLUDE_DEFAULTS
|
|
+#define INCLUDE_DEFAULTS \
|
|
+ { \
|
|
+ INCLUDE_DEFAULTS_MUSL_GPP \
|
|
+ INCLUDE_DEFAULTS_MUSL_PREFIX \
|
|
+ INCLUDE_DEFAULTS_MUSL_CROSS \
|
|
+ INCLUDE_DEFAULTS_MUSL_TOOL \
|
|
+ INCLUDE_DEFAULTS_MUSL_NATIVE \
|
|
+ { GCC_INCLUDE_DIR, "GCC", 0, 1, 0, 0 }, \
|
|
+ { 0, 0, 0, 0, 0, 0 } \
|
|
+ }
|
|
+#endif
|
|
Index: b/gcc/config/linux.opt
|
|
===================================================================
|
|
--- a/gcc/config/linux.opt
|
|
+++ b/gcc/config/linux.opt
|
|
@@ -30,3 +30,7 @@
|
|
muclibc
|
|
Target Report RejectNegative Var(linux_libc,LIBC_UCLIBC) Negative(mbionic)
|
|
Use uClibc C library
|
|
+
|
|
+mmusl
|
|
+Target Report RejectNegative Var(linux_libc,LIBC_MUSL) Negative(mglibc)
|
|
+Use musl C library
|
|
Index: b/gcc/ginclude/stddef.h
|
|
===================================================================
|
|
--- a/gcc/ginclude/stddef.h
|
|
+++ b/gcc/ginclude/stddef.h
|
|
@@ -184,6 +184,7 @@
|
|
#ifndef _GCC_SIZE_T
|
|
#ifndef _SIZET_
|
|
#ifndef __size_t
|
|
+#ifndef __DEFINED_size_t /* musl */
|
|
#define __size_t__ /* BeOS */
|
|
#define __SIZE_T__ /* Cray Unicos/Mk */
|
|
#define _SIZE_T
|
|
@@ -200,6 +201,7 @@
|
|
#define ___int_size_t_h
|
|
#define _GCC_SIZE_T
|
|
#define _SIZET_
|
|
+#define __DEFINED_size_t /* musl */
|
|
#if (defined (__FreeBSD__) && (__FreeBSD__ >= 5)) \
|
|
|| defined(__FreeBSD_kernel__)
|
|
/* __size_t is a typedef on FreeBSD 5, must not trash it. */
|
|
@@ -215,6 +217,7 @@
|
|
typedef long ssize_t;
|
|
#endif /* __BEOS__ */
|
|
#endif /* !(defined (__GNUG__) && defined (size_t)) */
|
|
+#endif /* __DEFINED_size_t */
|
|
#endif /* __size_t */
|
|
#endif /* _SIZET_ */
|
|
#endif /* _GCC_SIZE_T */
|
|
Index: b/libgomp/config/posix/time.c
|
|
===================================================================
|
|
--- a/libgomp/config/posix/time.c
|
|
+++ b/libgomp/config/posix/time.c
|
|
@@ -28,6 +28,8 @@
|
|
The following implementation uses the most simple POSIX routines.
|
|
If present, POSIX 4 clocks should be used instead. */
|
|
|
|
+#define _POSIX_C_SOURCE 199309L /* for clocks */
|
|
+
|
|
#include "libgomp.h"
|
|
#include <unistd.h>
|
|
#if TIME_WITH_SYS_TIME
|
|
Index: b/libgcc/unwind-dw2-fde-dip.c
|
|
===================================================================
|
|
--- a/libgcc/unwind-dw2-fde-dip.c
|
|
+++ b/libgcc/unwind-dw2-fde-dip.c
|
|
@@ -71,6 +71,13 @@
|
|
# define USE_PT_GNU_EH_FRAME
|
|
#endif
|
|
|
|
+/* For musl libc, TARGET_DL_ITERATE_PHDR gets defined by the configure
|
|
+ script. */
|
|
+#if !defined(inhibit_libc) && defined(HAVE_LD_EH_FRAME_HDR) \
|
|
+ && defined(TARGET_DL_ITERATE_PHDR)
|
|
+# define USE_PT_GNU_EH_FRAME
|
|
+#endif
|
|
+
|
|
#if defined(USE_PT_GNU_EH_FRAME)
|
|
|
|
#include <link.h>
|
|
Index: b/gcc/configure
|
|
===================================================================
|
|
--- a/gcc/configure
|
|
+++ b/gcc/configure
|
|
@@ -26906,6 +26910,9 @@
|
|
gcc_cv_target_dl_iterate_phdr=no
|
|
fi
|
|
;;
|
|
+ *-linux-musl*)
|
|
+ gcc_cv_target_dl_iterate_phdr=yes
|
|
+ ;;
|
|
esac
|
|
|
|
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
|
Index: b/gcc/configure.ac
|
|
===================================================================
|
|
--- a/gcc/configure.ac
|
|
+++ b/gcc/configure.ac
|
|
@@ -4767,6 +4771,9 @@
|
|
gcc_cv_target_dl_iterate_phdr=no
|
|
fi
|
|
;;
|
|
+ *-linux-musl*)
|
|
+ gcc_cv_target_dl_iterate_phdr=yes
|
|
+ ;;
|
|
esac
|
|
GCC_TARGET_TEMPLATE([TARGET_DL_ITERATE_PHDR])
|
|
if test x$gcc_cv_target_dl_iterate_phdr = xyes; then
|
|
Index: b/fixincludes/mkfixinc.sh
|
|
===================================================================
|
|
--- a/fixincludes/mkfixinc.sh
|
|
+++ b/fixincludes/mkfixinc.sh
|
|
@@ -20,7 +20,8 @@
|
|
powerpc-*-eabi* | \
|
|
powerpc-*-rtems* | \
|
|
powerpcle-*-eabisim* | \
|
|
- powerpcle-*-eabi* )
|
|
+ powerpcle-*-eabi* | \
|
|
+ *-musl* )
|
|
# IF there is no include fixing,
|
|
# THEN create a no-op fixer and exit
|
|
(echo "#! /bin/sh" ; echo "exit 0" ) > ${target}
|
|
Index: b/gcc/config/i386/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/i386/linux.h
|
|
+++ b/gcc/config/i386/linux.h
|
|
@@ -22,3 +22,5 @@
|
|
|
|
#define GNU_USER_LINK_EMULATION "elf_i386"
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
|
+#undef MUSL_DYNAMIC_LINKER
|
|
+#define MUSL_DYNAMIC_LINKER "/lib/ld-musl-i386.so.1"
|
|
Index: b/gcc/config/i386/linux64.h
|
|
===================================================================
|
|
--- a/gcc/config/i386/linux64.h
|
|
+++ b/gcc/config/i386/linux64.h
|
|
@@ -31,3 +31,10 @@
|
|
#define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
|
|
#define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux-x86-64.so.2"
|
|
#define GLIBC_DYNAMIC_LINKERX32 "/libx32/ld-linux-x32.so.2"
|
|
+
|
|
+#undef MUSL_DYNAMIC_LINKER32
|
|
+#undef MUSL_DYNAMIC_LINKER64
|
|
+#undef MUSL_DYNAMIC_LINKERX32
|
|
+#define MUSL_DYNAMIC_LINKER32 "/lib/ld-musl-i386.so.1"
|
|
+#define MUSL_DYNAMIC_LINKER64 "/lib/ld-musl-x86_64.so.1"
|
|
+#define MUSL_DYNAMIC_LINKERX32 "/lib/ld-musl-x32.so.1"
|
|
Index: b/libitm/config/linux/x86/tls.h
|
|
===================================================================
|
|
--- a/libitm/config/linux/x86/tls.h
|
|
+++ b/libitm/config/linux/x86/tls.h
|
|
@@ -25,16 +25,19 @@
|
|
#ifndef LIBITM_X86_TLS_H
|
|
#define LIBITM_X86_TLS_H 1
|
|
|
|
-#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 10)
|
|
+#if defined(__GLIBC_PREREQ)
|
|
+#if __GLIBC_PREREQ(2, 10)
|
|
/* Use slots in the TCB head rather than __thread lookups.
|
|
GLIBC has reserved words 10 through 13 for TM. */
|
|
#define HAVE_ARCH_GTM_THREAD 1
|
|
#define HAVE_ARCH_GTM_THREAD_DISP 1
|
|
#endif
|
|
+#endif
|
|
|
|
#include "config/generic/tls.h"
|
|
|
|
-#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 10)
|
|
+#if defined(__GLIBC_PREREQ)
|
|
+#if __GLIBC_PREREQ(2, 10)
|
|
namespace GTM HIDDEN {
|
|
|
|
#ifdef __x86_64__
|
|
@@ -101,5 +104,6 @@
|
|
|
|
} // namespace GTM
|
|
#endif /* >= GLIBC 2.10 */
|
|
+#endif
|
|
|
|
#endif // LIBITM_X86_TLS_H
|
|
Index: b/gcc/config/arm/linux-eabi.h
|
|
===================================================================
|
|
--- a/gcc/config/arm/linux-eabi.h
|
|
+++ b/gcc/config/arm/linux-eabi.h
|
|
@@ -64,6 +64,23 @@
|
|
#undef GLIBC_DYNAMIC_LINKER
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.3"
|
|
|
|
+/* For ARM musl currently supports four dynamic linkers:
|
|
+ - ld-musl-arm.so.1 - for the EABI-derived soft-float ABI
|
|
+ - ld-musl-armhf.so.1 - for the EABI-derived hard-float ABI
|
|
+ - ld-musl-armeb.so.1 - for the EABI-derived soft-float ABI, EB
|
|
+ - ld-musl-armebhf.so.1 - for the EABI-derived hard-float ABI, EB
|
|
+ musl does not support the legacy OABI mode.
|
|
+ All the dynamic linkers live in /lib.
|
|
+ We default to soft-float, EL. */
|
|
+#undef MUSL_DYNAMIC_LINKER
|
|
+#if TARGET_BIG_ENDIAN_DEFAULT
|
|
+#define MUSL_DYNAMIC_LINKER_E "%{mlittle-endian:;:eb}"
|
|
+#else
|
|
+#define MUSL_DYNAMIC_LINKER_E "%{mbig-endian:eb}"
|
|
+#endif
|
|
+#define MUSL_DYNAMIC_LINKER \
|
|
+ "/lib/ld-musl-arm" MUSL_DYNAMIC_LINKER_E "%{mfloat-abi=hard:hf}.so.1"
|
|
+
|
|
/* At this point, bpabi.h will have clobbered LINK_SPEC. We want to
|
|
use the GNU/Linux version, not the generic BPABI version. */
|
|
#undef LINK_SPEC
|
|
Index: b/libitm/config/arm/hwcap.cc
|
|
===================================================================
|
|
--- a/libitm/config/arm/hwcap.cc
|
|
+++ b/libitm/config/arm/hwcap.cc
|
|
@@ -40,7 +40,11 @@
|
|
|
|
#ifdef __linux__
|
|
#include <unistd.h>
|
|
+#ifdef __GLIBC__
|
|
#include <sys/fcntl.h>
|
|
+#else
|
|
+#include <fcntl.h>
|
|
+#endif
|
|
#include <elf.h>
|
|
|
|
static void __attribute__((constructor))
|
|
Index: b/gcc/config/mips/linux.h
|
|
===================================================================
|
|
--- a/gcc/config/mips/linux.h
|
|
+++ b/gcc/config/mips/linux.h
|
|
@@ -19,3 +19,11 @@
|
|
<http://www.gnu.org/licenses/>. */
|
|
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
|
|
+
|
|
+#if TARGET_ENDIAN_DEFAULT == 0 /* LE */
|
|
+#define MUSL_DYNAMIC_LINKER_E "%{EB:;:el}"
|
|
+#else
|
|
+#define MUSL_DYNAMIC_LINKER_E "%{EL:el}"
|
|
+#endif
|
|
+#undef MUSL_DYNAMIC_LINKER
|
|
+#define MUSL_DYNAMIC_LINKER "/lib/ld-musl-mips" MUSL_DYNAMIC_LINKER_E ".so.1"
|
|
Index: b/gcc/config/rs6000/linux64.h
|
|
===================================================================
|
|
--- a/gcc/config/rs6000/linux64.h
|
|
+++ b/gcc/config/rs6000/linux64.h
|
|
@@ -362,17 +362,23 @@
|
|
#define GLIBC_DYNAMIC_LINKER64 "/lib64/ld64.so.1"
|
|
#define UCLIBC_DYNAMIC_LINKER32 "/lib/ld-uClibc.so.0"
|
|
#define UCLIBC_DYNAMIC_LINKER64 "/lib/ld64-uClibc.so.0"
|
|
+#undef MUSL_DYNAMIC_LINKER32
|
|
+#undef MUSL_DYNAMIC_LINKER64
|
|
+#define MUSL_DYNAMIC_LINKER32 "/lib/ld-musl-powerpc.so.1"
|
|
+#define MUSL_DYNAMIC_LINKER64 "/lib/ld-musl-powerpc64.so.1"
|
|
#if DEFAULT_LIBC == LIBC_UCLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U) "%{mglibc:" G ";:" U "}"
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{mglibc:" G ";:%{mmusl:" M ";:" U "}}"
|
|
#elif DEFAULT_LIBC == LIBC_GLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U) "%{muclibc:" U ";:" G "}"
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{muclibc:" U ";:%{mmusl:" M ";:" G "}}"
|
|
+#elif DEFAULT_LIBC == LIBC_MUSL
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{mglibc:" G ";:%{muclibc:" U ";:" M "}}"
|
|
#else
|
|
#error "Unsupported DEFAULT_LIBC"
|
|
#endif
|
|
#define GNU_USER_DYNAMIC_LINKER32 \
|
|
- CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER32, UCLIBC_DYNAMIC_LINKER32)
|
|
+ CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER32, UCLIBC_DYNAMIC_LINKER32, MUSL_DYNAMIC_LINKER32)
|
|
#define GNU_USER_DYNAMIC_LINKER64 \
|
|
- CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64)
|
|
+ CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64, MUSL_DYNAMIC_LINKER64)
|
|
|
|
|
|
#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux %{!shared: %{!static: \
|
|
Index: b/gcc/config/rs6000/secureplt.h
|
|
===================================================================
|
|
--- a/gcc/config/rs6000/secureplt.h
|
|
+++ b/gcc/config/rs6000/secureplt.h
|
|
@@ -18,3 +18,4 @@
|
|
<http://www.gnu.org/licenses/>. */
|
|
|
|
#define CC1_SECURE_PLT_DEFAULT_SPEC "-msecure-plt"
|
|
+#define LINK_SECURE_PLT_DEFAULT_SPEC "--secure-plt"
|
|
Index: b/gcc/config/rs6000/sysv4.h
|
|
===================================================================
|
|
--- a/gcc/config/rs6000/sysv4.h
|
|
+++ b/gcc/config/rs6000/sysv4.h
|
|
@@ -566,6 +566,9 @@
|
|
#ifndef CC1_SECURE_PLT_DEFAULT_SPEC
|
|
#define CC1_SECURE_PLT_DEFAULT_SPEC ""
|
|
#endif
|
|
+#ifndef LINK_SECURE_PLT_DEFAULT_SPEC
|
|
+#define LINK_SECURE_PLT_DEFAULT_SPEC ""
|
|
+#endif
|
|
|
|
/* Pass -G xxx to the compiler and set correct endian mode. */
|
|
#define CC1_SPEC "%{G*} %(cc1_cpu) \
|
|
@@ -626,7 +629,8 @@
|
|
%{mlittle: --oformat elf32-powerpcle } %{mlittle-endian: --oformat elf32-powerpcle } \
|
|
%{!mlittle: %{!mlittle-endian: %{!mbig: %{!mbig-endian: \
|
|
%{mcall-i960-old: --oformat elf32-powerpcle} \
|
|
- }}}}"
|
|
+ }}}} \
|
|
+%{!mbss-plt: %{!msecure-plt: %(link_secure_plt_default)}}"
|
|
|
|
/* Any specific OS flags. */
|
|
#define LINK_OS_SPEC "\
|
|
@@ -804,15 +808,19 @@
|
|
|
|
#define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
|
|
#define UCLIBC_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
|
|
+#undef MUSL_DYNAMIC_LINKER
|
|
+#define MUSL_DYNAMIC_LINKER "/lib/ld-musl-powerpc.so.1"
|
|
#if DEFAULT_LIBC == LIBC_UCLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U) "%{mglibc:" G ";:" U "}"
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{mglibc:" G ";:%{mmusl:" M ";:" U "}}"
|
|
+#elif DEFAULT_LIBC == LIBC_MUSL
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{mglibc:" G ";:%{muclibc:" U ";:" M "}}"
|
|
#elif !defined (DEFAULT_LIBC) || DEFAULT_LIBC == LIBC_GLIBC
|
|
-#define CHOOSE_DYNAMIC_LINKER(G, U) "%{muclibc:" U ";:" G "}"
|
|
+#define CHOOSE_DYNAMIC_LINKER(G, U, M) "%{muclibc:" U ";:%{mmusl:" M ";:" G "}}"
|
|
#else
|
|
#error "Unsupported DEFAULT_LIBC"
|
|
#endif
|
|
#define GNU_USER_DYNAMIC_LINKER \
|
|
- CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER)
|
|
+ CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER, MUSL_DYNAMIC_LINKER)
|
|
|
|
#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
|
%{rdynamic:-export-dynamic} \
|
|
@@ -938,6 +946,7 @@
|
|
{ "cc1_endian_little", CC1_ENDIAN_LITTLE_SPEC }, \
|
|
{ "cc1_endian_default", CC1_ENDIAN_DEFAULT_SPEC }, \
|
|
{ "cc1_secure_plt_default", CC1_SECURE_PLT_DEFAULT_SPEC }, \
|
|
+ { "link_secure_plt_default", LINK_SECURE_PLT_DEFAULT_SPEC }, \
|
|
{ "cpp_os_ads", CPP_OS_ADS_SPEC }, \
|
|
{ "cpp_os_yellowknife", CPP_OS_YELLOWKNIFE_SPEC }, \
|
|
{ "cpp_os_mvme", CPP_OS_MVME_SPEC }, \
|
|
Index: b/gcc/config/mips/linux64.h
|
|
===================================================================
|
|
--- a/gcc/config/mips/linux64.h
|
|
+++ b/gcc/config/mips/linux64.h
|
|
@@ -30,4 +30,4 @@
|
|
#define BIONIC_DYNAMIC_LINKERN32 "/system/bin/linker32"
|
|
#define GNU_USER_DYNAMIC_LINKERN32 \
|
|
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKERN32, UCLIBC_DYNAMIC_LINKERN32, \
|
|
- BIONIC_DYNAMIC_LINKERN32)
|
|
+ BIONIC_DYNAMIC_LINKERN32, MUSL_DYNAMIC_LINKER)
|