274e5f6731
Remove patches that have been applied upstream and adapt the other ones. Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
75 lines
2.0 KiB
Diff
75 lines
2.0 KiB
Diff
Description: remove make targets for deps
|
|
Without this patch, dependencies would be downloaded and compiled
|
|
using rebar at build time.
|
|
Author: Philipp Huebner <debalance@debian.org>
|
|
|
|
Index: ejabberd/Makefile.in
|
|
===================================================================
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index f7b30d4..4ca4db3 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -74,26 +74,11 @@ else
|
|
INIT_USER=$(INSTALLUSER)
|
|
endif
|
|
|
|
-all: deps src
|
|
+all: src
|
|
|
|
-deps: deps/.got
|
|
-
|
|
-deps/.got:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- $(REBAR) get-deps && :> deps/.got
|
|
-
|
|
-deps/.built: deps/.got
|
|
- $(REBAR) compile && :> deps/.built
|
|
-
|
|
-src: deps/.built
|
|
+src:
|
|
$(REBAR) skip_deps=true compile
|
|
|
|
-update:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- $(REBAR) update-deps && :> deps/.got
|
|
-
|
|
xref: all
|
|
$(REBAR) skip_deps=true xref
|
|
|
|
@@ -109,8 +94,6 @@ spec:
|
|
$(ERL) -noinput +B -pa ebin -pa deps/*/ebin -eval \
|
|
'case xml_gen:compile("tools/xmpp_codec.spec") of ok -> halt(0); _ -> halt(1) end.'
|
|
|
|
-DLLs := $(wildcard deps/*/priv/*.so) $(wildcard deps/*/priv/lib/*.so)
|
|
-
|
|
install: all
|
|
#
|
|
# Configuration files
|
|
@@ -151,8 +134,6 @@ install: all
|
|
$(INSTALL) -d $(BEAMDIR)
|
|
$(INSTALL) -m 644 ebin/*.app $(BEAMDIR)
|
|
$(INSTALL) -m 644 ebin/*.beam $(BEAMDIR)
|
|
- $(INSTALL) -m 644 deps/*/ebin/*.app $(BEAMDIR)
|
|
- $(INSTALL) -m 644 deps/*/ebin/*.beam $(BEAMDIR)
|
|
# Install Elixir and Elixir dependancies
|
|
-$(INSTALL) -m 644 deps/*/lib/*/ebin/*.app $(BEAMDIR)
|
|
-$(INSTALL) -m 644 deps/*/lib/*/ebin/*.beam $(BEAMDIR)
|
|
@@ -161,7 +142,6 @@ install: all
|
|
# ejabberd header files
|
|
$(INSTALL) -d $(INCLUDEDIR)
|
|
$(INSTALL) -m 644 include/*.hrl $(INCLUDEDIR)
|
|
- $(INSTALL) -m 644 deps/*/include/*.hrl $(INCLUDEDIR)
|
|
#
|
|
# Binary C programs
|
|
$(INSTALL) -d $(PBINDIR)
|
|
@@ -174,7 +154,6 @@ install: all
|
|
#
|
|
# Binary system libraries
|
|
$(INSTALL) -d $(SODIR)
|
|
- $(INSTALL) -m 644 $(DLLs) $(SODIR)
|
|
[ -f $(SODIR)/jiffy.so ] && (cd $(PRIVDIR); ln -s lib/jiffy.so; true) || true
|
|
[ -f $(SODIR)/sqlite3_drv.so ] && (cd $(PRIVDIR); ln -s lib/sqlite3_drv.so; true) || true
|
|
#
|