0ce776942d
Fix the following security issues:
- https://www.wireshark.org/security/wnpa-sec-2021-07.html
(CVE-2021-39929)
- https://www.wireshark.org/security/wnpa-sec-2021-08.html
(CVE-2021-39926)
- https://www.wireshark.org/security/wnpa-sec-2021-09.html
(CVE-2021-39925)
- https://www.wireshark.org/security/wnpa-sec-2021-10.html
(CVE-2021-39924)
- https://www.wireshark.org/security/wnpa-sec-2021-11.html
- https://www.wireshark.org/security/wnpa-sec-2021-12.html
(CVE-2021-39922)
- https://www.wireshark.org/security/wnpa-sec-2021-13.html
(CVE-2021-39928)
- https://www.wireshark.org/security/wnpa-sec-2021-14.html
(CVE-2021-39921)
- https://www.wireshark.org/security/wnpa-sec-2021-15.html
(CVE-2021-39920)
Drop WIRESHARK_BUILD_LEMON_TOOL and set LEMON_C_COMPILER which is
available since
61e66c37ab
https://www.wireshark.org/docs/relnotes/wireshark-3.4.10.html
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
990 B
Diff
31 lines
990 B
Diff
From 982e5ab072816e29f6f2dc84d9a00ee7c4fdee40 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Fri, 26 Nov 2021 17:45:23 +0100
|
|
Subject: [PATCH] cmake: lemon: wipe CMAKE_SYSROOT if needed
|
|
|
|
Wipe CMAKE_SYSROOT when LEMON_C_COMPILER is set to avoid a build failure
|
|
when cross-compiling (e.g. with buildroot)
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status:
|
|
https://gitlab.com/wireshark/wireshark/-/merge_requests/5224]
|
|
---
|
|
tools/lemon/CMakeLists.txt | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/tools/lemon/CMakeLists.txt b/tools/lemon/CMakeLists.txt
|
|
index 8742aa9fc9..7c8cc23a35 100644
|
|
--- a/tools/lemon/CMakeLists.txt
|
|
+++ b/tools/lemon/CMakeLists.txt
|
|
@@ -12,6 +12,7 @@ add_executable(lemon lemon.c)
|
|
if(DEFINED LEMON_C_COMPILER)
|
|
set(CMAKE_C_COMPILER "${LEMON_C_COMPILER}")
|
|
set(CMAKE_C_FLAGS "")
|
|
+ set(CMAKE_SYSROOT "")
|
|
endif()
|
|
|
|
# To keep lemon.c as close to upstream as possible, deliberately ignore
|
|
--
|
|
2.33.0
|
|
|