e68bcc985f
Updated dependencies after upstream commitdbb8853696
Although glm depends on BR2_INSTALL_LIBSTDCPP this dependency was not added because Kodi itself already depends on C++. Also removed patch 0002 because this package has no direct dependency for X libraries anymore. Removed patch 0001 which was applied upstreamb9dda499db
Added patch to disable building the drempels screensaver which depends on imagemagick6. Even though rsxs has a minimal bundled imagemagick, we simply disable drempels to avoid using a bundled library. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
From 28c01686ba0d67d317e058776f01efba5e6471bd Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Sat, 13 Jul 2019 14:18:12 +0200
|
|
Subject: [PATCH] Disable drempels
|
|
|
|
Does not build with ImageMagick 7.x:
|
|
|
|
src/drempels/TexMgr.cpp:31:10: fatal error: magick/api.h:
|
|
No such file or directory
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
CMakeLists.txt | 4 +---
|
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index a86ccd0..b5ca03f 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -40,8 +40,7 @@ include_directories(${KODI_INCLUDE_DIR}/.. # Hack way with "/..", need bigger Ko
|
|
if(ImageMagick_FOUND AND NOT ${OWN_IMAGE_MAGICK})
|
|
message(STATUS "ImageMagick found in the system and is used")
|
|
else()
|
|
- message(STATUS "ImageMagick not found or forced and add custom created")
|
|
- add_subdirectory(lib/ImageMagick)
|
|
+ message(STATUS "ImageMagick not found")
|
|
endif()
|
|
add_subdirectory(lib/kodi/gui/gl)
|
|
add_subdirectory(lib/Implicit)
|
|
@@ -70,7 +69,6 @@ include(src/biof/CMakeLists.txt)
|
|
include(src/busyspheres/CMakeLists.txt)
|
|
include(src/colorfire/CMakeLists.txt)
|
|
include(src/cyclone/CMakeLists.txt)
|
|
-include(src/drempels/CMakeLists.txt)
|
|
include(src/euphoria/CMakeLists.txt)
|
|
include(src/feedback/CMakeLists.txt)
|
|
include(src/fieldlines/CMakeLists.txt)
|
|
--
|
|
2.20.1
|
|
|