2e8a777373
granite fails to build since bump to vala 0.46.6 in commit2723ff3333
: make[3]: Leaving directory '/tmp/instance-0/output-1/build/granite-0.4.1' [ 1%] Generating style-classes.c;Application.c;Drawing/Color.c;Drawing/BufferSurface.c;Drawing/Utilities.c;GtkPatch/AboutDialog.c;Services/Settings.c;Services/Logger.c;Services/Paths.c;Services/System.c;Services/Contractor.c;Services/ContractorProxy.c;Services/IconFactory.c;Services/SimpleCommand.c;Widgets/AlertView.c;Widgets/Avatar.c;Widgets/Utils.c;Widgets/WrapLabel.c;Widgets/AboutDialog.c;Widgets/ModeButton.c;Widgets/DatePicker.c;Widgets/Entries.c;Widgets/TimePicker.c;Widgets/CollapsiblePaned.c;Widgets/StaticNotebook.c;Widgets/DynamicNotebook.c;Widgets/CompositedWindow.c;Widgets/AppMenu.c;Widgets/Welcome.c;Widgets/WelcomeButton.c;Widgets/Toast.c;Widgets/ToolButtonWithMenu.c;Widgets/PopOver.c;Widgets/ContractorView.c;Widgets/ContractorMenu.c;Widgets/DecoratedWindow.c;Widgets/LightWindow.c;Widgets/StatusBar.c;Widgets/SidebarPaned.c;Widgets/StorageBar.c;Widgets/SourceList.c;Widgets/CellRendererExpander.c;Widgets/CellRendererBadge.c;Widgets/ThinPaned.c;Widgets/OverlayBar.c;gr anite.vapi;granite.h make[3]: Entering directory '/tmp/instance-0/output-1/build/granite-0.4.1' /tmp/instance-0/output-1/build/granite-0.4.1/lib/Application.vala:145.9-145.26: error: Creation method of abstract class cannot be public. public Application () { ^^^^^^^^^^^^^^^^^^ So bump granite to latest version to include the following commit (that does not apply cleanly on current version):fd26013c84
Moreover: - Switch site to github to get latest release - Switch to meson-package - Add gobject-introspection optional dependency Fixes: - http://autobuild.buildroot.org/results/3e2cc89b9bd42824731d0c7b39dd5b5c98e527ee Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
74 lines
2.3 KiB
Diff
74 lines
2.3 KiB
Diff
From 4d5ddcdb9c03d4e829fe7080e497a00f0b379eff Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sun, 14 Jun 2020 17:33:31 +0200
|
|
Subject: [PATCH] meson: add introspection option
|
|
|
|
This will allow the user to build granite without gobject-introspection
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/elementary/granite/pull/410]
|
|
---
|
|
lib/meson.build | 38 ++++++++++++++++++++------------------
|
|
meson_options.txt | 1 +
|
|
2 files changed, 21 insertions(+), 18 deletions(-)
|
|
|
|
diff --git a/lib/meson.build b/lib/meson.build
|
|
index a9fc4ed4..770feeb5 100644
|
|
--- a/lib/meson.build
|
|
+++ b/lib/meson.build
|
|
@@ -98,24 +98,26 @@ install_data(
|
|
install_dir: include_dir
|
|
)
|
|
|
|
-# typelib generation isn't automated yet
|
|
-g_ir_compiler = find_program('g-ir-compiler')
|
|
-custom_target(
|
|
- granite_typelib,
|
|
- command: [
|
|
- g_ir_compiler,
|
|
- '--shared-library',
|
|
- '@PLAINNAME@',
|
|
- '--output',
|
|
- '@OUTPUT@',
|
|
- join_paths(meson.current_build_dir(), granite_gir),
|
|
- ],
|
|
- input: libgranite,
|
|
- output: granite_typelib,
|
|
- depends: libgranite,
|
|
- install: true,
|
|
- install_dir: join_paths(get_option('libdir'), 'girepository-1.0'),
|
|
-)
|
|
+if get_option('introspection')
|
|
+ # typelib generation isn't automated yet
|
|
+ g_ir_compiler = find_program('g-ir-compiler')
|
|
+ custom_target(
|
|
+ granite_typelib,
|
|
+ command: [
|
|
+ g_ir_compiler,
|
|
+ '--shared-library',
|
|
+ '@PLAINNAME@',
|
|
+ '--output',
|
|
+ '@OUTPUT@',
|
|
+ join_paths(meson.current_build_dir(), granite_gir),
|
|
+ ],
|
|
+ input: libgranite,
|
|
+ output: granite_typelib,
|
|
+ depends: libgranite,
|
|
+ install: true,
|
|
+ install_dir: join_paths(get_option('libdir'), 'girepository-1.0'),
|
|
+ )
|
|
+endif
|
|
|
|
libgranite_dep = declare_dependency(
|
|
link_with: libgranite,
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index 9d9f62e9..bd1a1d6f 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -1 +1,2 @@
|
|
option('documentation', type: 'boolean', value: false, description: 'generate documentation with gtk-doc and valadoc')
|
|
+option('introspection', type: 'boolean', value: true, description: 'Whether to build introspection files')
|
|
--
|
|
2.26.2
|
|
|