kumquat-buildroot/package/pulseaudio/0002-musl-fixes.patch
Bernd Kuhls 1cffb45432 package/pulseaudio: fix musl build
Fixes build errors in previous version which are still present
http://autobuild.buildroot.net/results/879/879260f0efc80c2c9061d89d3e99ad107083f72a/
http://autobuild.buildroot.net/results/1e5/1e5f6a5f349800226d8b07601dab68ffe7794461/
http://autobuild.buildroot.net/results/0f8/0f8d68b11c6807a9d1d4c40a66430ac096902720/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Romain Naour <romain.naour@gmail.com>

[Thomas:
 - Rework patch 0001-padsp-Make-it-compile-on-musl.patch to put
   Bernd's comment and SoB *after* the original commit log.
 - Rework patch 0002-musl-fixes.patch for the same reason, and also to
   remove the xlocale.h part, which has already been fixed upstream.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-02-07 15:21:56 +01:00

42 lines
1.4 KiB
Diff

Portability fixes for musl taken from voidlinux:
- _WORDIZE is declared in <bits/user.h> via <sys/user.h>.
--xtraeme
[Bernd: Downloaded from
http://git.alpinelinux.org/cgit/aports/tree/testing/pulseaudio/musl-fixes.patch
and adjusted paths.]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: remove xlocale.h part, it was fixed upstream.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
--- a/configure.ac.orig 2015-09-24 11:36:06.107661526 +0200
+++ b/configure.ac 2015-09-24 11:36:40.420036775 +0200
@@ -407,7 +407,7 @@ AC_HEADER_STDC
# POSIX
AC_CHECK_HEADERS_ONCE([arpa/inet.h glob.h grp.h netdb.h netinet/in.h \
netinet/in_systm.h netinet/tcp.h poll.h pwd.h sched.h \
- sys/mman.h sys/select.h sys/socket.h sys/wait.h \
+ sys/mman.h sys/select.h sys/socket.h sys/wait.h sys/user.h \
sys/uio.h syslog.h sys/dl.h dlfcn.h linux/sockios.h])
AC_CHECK_HEADERS([netinet/ip.h], [], [],
[#include <sys/types.h>
--- a/src/pulsecore/sample-util.h.orig 2015-09-24 11:37:57.773677238 +0200
+++ b/src/pulsecore/sample-util.h 2015-09-24 11:38:46.668208677 +0200
@@ -24,6 +24,14 @@
#include <inttypes.h>
#include <limits.h>
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#ifdef HAVE_SYS_USER_H
+#include <sys/user.h> /* required by _WORDIZE with musl */
+#endif
+
#include <pulse/gccmacro.h>
#include <pulse/sample.h>
#include <pulse/volume.h>