fbde3a6c95
Update wayland to version 1.19.0, which mostly includes bug fixes and is the minimum version required by wlroots 0.13.0 Patch "0001-build-add-option-to-disable-tests.patch" is updated as an actual backport from upstream. Since upstream has migrated to meson, and we've already switched too, drop the autostuff hunks. Patch "0002-meson-do-not-check-for-c.patch" is replaced by a newer one, "0002-meson-only-require-cpp-for-tests.patch" which was accepted by upstream as an improved version of it. Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> [yann.morin.1998@free.fr: - do actual backports of upstream patches now they've been merged - consequently, drop the legacy autostuff hunks from first patch ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
59 lines
1.7 KiB
Diff
59 lines
1.7 KiB
Diff
From 88f1605a826ca0c2ff02be6f4cf9ecabf68e8341 Mon Sep 17 00:00:00 2001
|
|
From: James Hilliard <james.hilliard1@gmail.com>
|
|
Date: Tue, 3 Mar 2020 15:27:51 -0700
|
|
Subject: [PATCH] build: add option to disable tests
|
|
|
|
When building for a product, tests are not needed.
|
|
|
|
Besides, one test requires a C++ compiler, which is not always
|
|
available.
|
|
|
|
So, add an option to configure to disable building tests altogether.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
|
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
|
[Upstream status:
|
|
https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/66]
|
|
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
|
[yann.morin.1998@free.fr: backport from upstream]
|
|
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
|
|
---
|
|
meson.build | 4 +++-
|
|
meson_options.txt | 4 ++++
|
|
2 files changed, 7 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index cdb66bc..714a86d 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -84,7 +84,9 @@ subdir('src')
|
|
if get_option('libraries')
|
|
subdir('cursor')
|
|
subdir('egl')
|
|
- subdir('tests')
|
|
+ if get_option('tests')
|
|
+ subdir('tests')
|
|
+ endif
|
|
if get_option('documentation')
|
|
subdir('doc')
|
|
endif
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index de588d1..4433fa0 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -6,6 +6,10 @@ option('scanner',
|
|
description: 'Compile wayland-scanner binary',
|
|
type: 'boolean',
|
|
value: 'true')
|
|
+option('tests',
|
|
+ description: 'Compile Wayland tests',
|
|
+ type: 'boolean',
|
|
+ value: 'true')
|
|
option('documentation',
|
|
description: 'Build the documentation (requires Doxygen, dot, xmlto, xsltproc)',
|
|
type: 'boolean',
|
|
--
|
|
2.25.1
|
|
|