134b9518ff
Release notes: https://lists.gnu.org/archive/html/info-gnu/2019-10/msg00000.html Removed patches applied upstream: - 0001-compiler-sanity-checks.patch https://git.savannah.gnu.org/cgit/screen.git/commit/?h=v.4.7.0&id=6b320186db7df1e58fdd2c836af54c86cc596981 - 0003-cross-compilation-AC_TRY_RUN.patch https://git.savannah.gnu.org/cgit/screen.git/commit/?h=v.4.7.0&id=abba47ce4206506c49858d944e904fff86ae65cc - 0004-cross-compilation-ignore-host-fs.patch https://git.savannah.gnu.org/cgit/screen.git/commit/?h=v.4.7.0&id=c573b89139e7a068f5573abd565605bed60f293f - 0005-avoid-identifying-as-SVR4.patch https://git.savannah.gnu.org/cgit/screen.git/commit/?h=v.4.7.0&id=ec90292592dd2c9d5c108390841e3df24e377ed5 Rebased 0001-no-memcpy-fallback.patch Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
30 lines
970 B
Diff
30 lines
970 B
Diff
From: Maarten ter Huurne <maarten@treewalker.org>
|
|
Date: Mon, 15 Sep 2014 00:03:05 +0200
|
|
Subject: Change binary permission flags even if chown fails
|
|
|
|
Typically when creating a package, the build is not run as root, so
|
|
the chown will fail. But the chmod can still be done.
|
|
|
|
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
|
|
---
|
|
Makefile.in | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 65549e9..3c12fdb 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -84,7 +84,8 @@ screen: $(OFILES)
|
|
|
|
install_bin: .version screen
|
|
$(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
|
|
- -chown root $(DESTDIR)$(bindir)/$(SCREEN) && chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
+ -chown root $(DESTDIR)$(bindir)/$(SCREEN)
|
|
+ -chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
# This doesn't work if $(bindir)/screen is a symlink
|
|
rm -f $(DESTDIR)$(bindir)/screen
|
|
(cd $(DESTDIR)$(bindir) && ln -f -s $(SCREEN) screen)
|
|
--
|
|
1.8.4.5
|
|
|