54d962b768
Drop first and second patches (already in version) https://github.com/xianyi/OpenBLAS/blob/v0.3.18/Changelog.txt Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
32 lines
1004 B
Diff
32 lines
1004 B
Diff
From ced08de1ad74811bc23d74121751537bfd8e9556 Mon Sep 17 00:00:00 2001
|
|
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
|
Date: Fri, 5 Mar 2021 11:15:52 +0100
|
|
Subject: [PATCH] Makefile: also consider -O, -Og and -Os when stripping flags
|
|
|
|
gcc also supports -O, -Og and -Os as optimization flags.
|
|
They may be given on the make command-line by users.
|
|
|
|
For the calculation of LAPACK_NOOPT, all such flags should be considered.
|
|
|
|
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index a22e16ba..fc5fe3f5 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -32,7 +32,7 @@ export NOFORTRAN
|
|
export NO_LAPACK
|
|
endif
|
|
|
|
-LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast,$(LAPACK_FFLAGS))
|
|
+LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast -O -Og -Os,$(LAPACK_FFLAGS))
|
|
|
|
SUBDIRS_ALL = $(SUBDIRS) test ctest utest exports benchmark ../laswp ../bench cpp_thread_test
|
|
|
|
--
|
|
2.26.2
|
|
|