ed7f7f7129
Drop uClibc-ng compatibility patch. Current uClibc-ng provides the needed definitions. Drop the libc-config.h musl compatibility workaround patch. iproute2 update its headers copy to current kernel version for which this workaround is no longer needed. Don't modify tc/Makefile to make XT_LIB_DIR get the value of IPT_LIB_DIR. Pass the correct value directly in CFLAGS. Add a patch removing arpd dependency on threading support. Rename IPROUTE2_WITH_IPTABLES to IPROUTE2_DISABLE_IPTABLES which better describes what it does. Don't patch the configure script for the cross compiler. The CC environment variable is enough. Don't force the CCOPTS make variable. The CFLAGS environment variable does the trick for target code. Don't patch CCOPTS out of netem/Makefile. The CBUILD_CFLAGS environment variable can pass the host CFLAGS to host code. The ifcfg script is now POSIX shell compatible. Remove its installation dependency on bash. Pass installation DESTDIR in the environment. Don't force SBINDIR, DOCDIR, and MANDIR. The default values are fine. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From 4a4f4d491f89bdd580fdd7a901a3300cb5e9789e Mon Sep 17 00:00:00 2001
|
|
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Tue, 1 May 2018 15:33:47 +0300
|
|
Subject: [PATCH] arpd: remove pthread dependency
|
|
|
|
Explicit link with pthread is not needed when linking dynamically. Even
|
|
static link with recent libdb does not pull in the code that uses
|
|
pthread. Finally, the configure check introduced in commit a25df4887d7
|
|
(configure: Check for Berkeley DB for arpd compilation) does not add
|
|
-lpthread to its link command.
|
|
|
|
This change allows arpd build with toolchains that do not provide
|
|
threads support.
|
|
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
Upstream status: http://patchwork.ozlabs.org/patch/907031/
|
|
|
|
misc/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/misc/Makefile b/misc/Makefile
|
|
index 34ef6b21b4ed..b2dd6b26e2dc 100644
|
|
--- a/misc/Makefile
|
|
+++ b/misc/Makefile
|
|
@@ -25,7 +25,7 @@ rtacct: rtacct.c
|
|
$(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o rtacct rtacct.c $(LDLIBS) -lm
|
|
|
|
arpd: arpd.c
|
|
- $(QUIET_CC)$(CC) $(CFLAGS) -I$(DBM_INCLUDE) $(LDFLAGS) -o arpd arpd.c $(LDLIBS) -ldb -lpthread
|
|
+ $(QUIET_CC)$(CC) $(CFLAGS) -I$(DBM_INCLUDE) $(LDFLAGS) -o arpd arpd.c $(LDLIBS) -ldb
|
|
|
|
ssfilter.c: ssfilter.y
|
|
$(QUIET_YACC)bison ssfilter.y -o ssfilter.c
|
|
--
|
|
2.17.0
|
|
|