3fed424566
Previously, we used support/scripts/pycompile.py to generate the pyc files for the python libraries. While the script worked, it did not follow the PEP 3147 layout requirements for py+pyc deployments. Now, use the package's own compileall.py script. This will follow PEP 3147 guidelines. It also supports "legacy" pyc only deployments as described here: https://peps.python.org/pep-3147/#case-4-legacy-pyc-files-and-source-less-imports With this change, we no longer need to hack support for side-by-side pyc files because files will be deployed as appropriate. This also has the added benefit of not requiring python3 on the host to build host-python3. Fixes: #14911 Signed-off-by: Vincent Fazio <vfazio@xes-inc.com> [yann.morin.1998@free.fr: - build-tested in a python-less environment - build+run-tested with the runtime-test infra ] Tested-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
43 lines
1.2 KiB
Diff
43 lines
1.2 KiB
Diff
From 146730a04dfe98e3d7971ebf5410801ceae88e11 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 23:31:11 +0100
|
|
Subject: [PATCH] Add options to disable zlib, bzip2 and xz modules
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 18 ++++++++++++++++++
|
|
1 file changed, 18 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 41a21ff..fa81bc7 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3433,6 +3433,24 @@ AC_ARG_ENABLE(readline,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(bzip2,
|
|
+ AS_HELP_STRING([--disable-bzip2], [disable bzip2]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _bz2"
|
|
+ fi])
|
|
+
|
|
+AC_ARG_ENABLE(zlib,
|
|
+ AS_HELP_STRING([--disable-zlib], [disable zlib]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} zlib"
|
|
+ fi])
|
|
+
|
|
+AC_ARG_ENABLE(xz,
|
|
+ AS_HELP_STRING([--disable-xz], [disable xz]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _lzma"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.30.2
|
|
|