87fb8365d8
Fixes: - http://autobuild.buildroot.org/results/e87b566f9c7d4ebebe57313fca4751939c197c88 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
54 lines
3.0 KiB
Diff
54 lines
3.0 KiB
Diff
From 2bd94884752b9840d434f80b1c4b83176f7063e3 Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Thu, 16 Jan 2020 08:52:00 -0800
|
|
Subject: [PATCH] carotene: Replace ipcp-unit-growth with ipa-cp-unit-growth on
|
|
gcc >= 10
|
|
|
|
gcc 10+ has renamed this option, therefore check for gcc version before
|
|
deciding which name to use for opt parameter
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
[Retrieved from:
|
|
https://github.com/opencv/opencv/commit/2bd94884752b9840d434f80b1c4b83176f7063e3]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
3rdparty/carotene/CMakeLists.txt | 7 +++++--
|
|
3rdparty/carotene/hal/CMakeLists.txt | 6 +++++-
|
|
2 files changed, 10 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/3rdparty/carotene/CMakeLists.txt b/3rdparty/carotene/CMakeLists.txt
|
|
index bfa9368d79d..528fcf62e15 100644
|
|
--- a/3rdparty/carotene/CMakeLists.txt
|
|
+++ b/3rdparty/carotene/CMakeLists.txt
|
|
@@ -20,8 +20,11 @@ if(CMAKE_COMPILER_IS_GNUCC)
|
|
# - matchTemplate about 5-10%
|
|
# - goodFeaturesToTrack 10-20%
|
|
# - cornerHarris 30% for some cases
|
|
-
|
|
- set_source_files_properties(${carotene_sources} COMPILE_FLAGS "--param ipcp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS "10.0.0")
|
|
+ set_source_files_properties(${carotene_sources} COMPILE_FLAGS "--param ipcp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ else()
|
|
+ set_source_files_properties(${carotene_sources} COMPILE_FLAGS "--param ipa-cp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ endif()
|
|
endif()
|
|
|
|
add_library(carotene_objs OBJECT
|
|
diff --git a/3rdparty/carotene/hal/CMakeLists.txt b/3rdparty/carotene/hal/CMakeLists.txt
|
|
index 819954de137..b94d8511e8a 100644
|
|
--- a/3rdparty/carotene/hal/CMakeLists.txt
|
|
+++ b/3rdparty/carotene/hal/CMakeLists.txt
|
|
@@ -88,7 +88,11 @@ set_property(DIRECTORY APPEND PROPERTY COMPILE_DEFINITIONS ${carotene_defs})
|
|
# matchTemplate about 5-10%
|
|
# goodFeaturesToTrack 10-20%
|
|
# cornerHarris 30% for some cases
|
|
- set_source_files_properties(impl.cpp $<TARGET_OBJECTS:carotene_objs> COMPILE_FLAGS "--param ipcp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ if(CMAKE_CXX_COMPILER_VERSION VERSION_LESS "10.0.0")
|
|
+ set_source_files_properties(impl.cpp $<TARGET_OBJECTS:carotene_objs> COMPILE_FLAGS "--param ipcp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ else()
|
|
+ set_source_files_properties(impl.cpp $<TARGET_OBJECTS:carotene_objs> COMPILE_FLAGS "--param ipa-cp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
+ endif()
|
|
# set_source_files_properties(impl.cpp $<TARGET_OBJECTS:carotene_objs> COMPILE_FLAGS "--param ipcp-unit-growth=100000 --param inline-unit-growth=100000 --param large-stack-frame-growth=5000")
|
|
endif()
|
|
|