ce81a6e6d2
Drop 0030-Fix-cross-compiling-the-uuid-module.patch as the patched code has been reworked upstream and python3 is built with --disable-uuid:91a51c5ffc
Rework 0033-configure.ac-fixup-CC-print-multiarch-output-for-mus.patch as the MULTIARCH code is now conditional on !darwin:9901d153c2
Refresh and renumber remaining patches. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
67 lines
2.5 KiB
Diff
67 lines
2.5 KiB
Diff
From 2eb05b69bb21df7884686ca2620612ac0f95b894 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:51:31 +0100
|
|
Subject: [PATCH] Add an option to disable decimal
|
|
|
|
This patch replaces the existing --with-system-libmpdec option with a
|
|
--with-libmpdec={system,builtin,none} option, which allows to tell
|
|
Python whether we want to use the system libmpdec (already installed),
|
|
the libmpdec builtin the Python sources, or no libmpdec at all.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[aduskett@gmail.com: Update for python 3.7.0]
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
[james.hilliard1@gmail.com: adapt to python 3.9]
|
|
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
|
---
|
|
configure.ac | 17 ++++++++++++-----
|
|
setup.py | 2 +-
|
|
2 files changed, 13 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2efd7a6de0..86fd03cdbb 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3142,13 +3142,20 @@ fi
|
|
AC_SUBST(LIBFFI_INCLUDEDIR)
|
|
|
|
# Check for use of the system libmpdec library
|
|
-AC_MSG_CHECKING(for --with-system-libmpdec)
|
|
-AC_ARG_WITH(system_libmpdec,
|
|
- AS_HELP_STRING([--with-system-libmpdec], [build _decimal module using an installed libmpdec library, see Doc/library/decimal.rst (default is no)]),
|
|
+AC_MSG_CHECKING(for --with-libmpdec)
|
|
+AC_ARG_WITH(libmpdec,
|
|
+ AS_HELP_STRING([--with-libmpdec], [select which libmpdec version to use: system, builtin, none]),
|
|
[],
|
|
- [with_system_libmpdec="no"])
|
|
+ [with_libmpdec="builtin"])
|
|
|
|
-AC_MSG_RESULT($with_system_libmpdec)
|
|
+AC_MSG_RESULT($with_libmpdec)
|
|
+if test "$with_libmpdec" != "none"; then
|
|
+ MPDEC=yes
|
|
+else
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _decimal"
|
|
+ MPDEC=no
|
|
+fi
|
|
+AC_SUBST(MPDEC)
|
|
|
|
# Check whether _decimal should use a coroutine-local or thread-local context
|
|
AC_MSG_CHECKING(for --with-decimal-contextvar)
|
|
diff --git a/setup.py b/setup.py
|
|
index 4f8cfcd28d..b471234473 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2202,7 +2202,7 @@ class PyBuildExt(build_ext):
|
|
# Stefan Krah's _decimal module
|
|
extra_compile_args = []
|
|
undef_macros = []
|
|
- if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
+ if '--with-libmpdec=system' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
include_dirs = []
|
|
libraries = [':libmpdec.so.2']
|
|
sources = ['_decimal/_decimal.c']
|
|
--
|
|
2.20.1
|
|
|