kumquat-buildroot/package/python-colorzero/python-colorzero.mk
Peter Seiderer 73bf3292e1 package/python-colorzero: bump version to 2.0
- change to python3 only

- update license file hash:
  @@ -1,4 +1,4 @@
  -Copyright 2016-2018 Dave Jones <dave@waveform.org.uk>
  +SPDX-License-Identifier: BSD-3-Clause

Changelog ([1]):

  - Dropped Python 2.x support. Current Python support level is 3.5 and above.

  - Added html and css format specifications to the :class:`Color` class'
    string-formatting capabilities.

[1] https://github.com/waveform80/colorzero/blob/master/docs/changelog.rst

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2021-04-22 21:34:02 +02:00

14 lines
466 B
Makefile

################################################################################
#
# python-colorzero
#
################################################################################
PYTHON_COLORZERO_VERSION = 2.0
PYTHON_COLORZERO_SITE = $(call github,waveform80,colorzero,release-$(PYTHON_COLORZERO_VERSION))
PYTHON_COLORZERO_LICENSE = BSD-3-Clause
PYTHON_COLORZERO_LICENSE_FILES = LICENSE.txt
PYTHON_COLORZERO_SETUP_TYPE = setuptools
$(eval $(python-package))