f1c092da8b
Some of the python2 patches were left behind when doing the python3 package. This was because the python build system can now autodetect what packages can be built in the system. However, some of these patches are actually useful to reduce drastically the size of the interpreter. This patch ports the relevant patches to the python3 package, and adds a new patch to remove the idle3 IDE as well from the interpreter. Fixes #5696 Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
27 lines
824 B
Diff
27 lines
824 B
Diff
Enables verbose output when building modules
|
|
|
|
Patch borrowed from OpenBricks.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
---
|
|
Makefile.pre.in | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
Index: Python-3.3.0/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-3.3.0.orig/Makefile.pre.in
|
|
+++ Python-3.3.0/Makefile.pre.in
|
|
@@ -476,10 +476,9 @@
|
|
|
|
# Build the shared modules
|
|
sharedmods: $(BUILDPYTHON) pybuilddir.txt
|
|
- case $$MAKEFLAGS in *s*) quiet=-q; esac; \
|
|
$(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
|
|
CONFIG_ARGS="$(CONFIG_ARGS)" \
|
|
- $(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
|
+ $(PYTHON_FOR_BUILD) $(srcdir)/setup.py build
|
|
|
|
# Build static library
|
|
# avoid long command lines, same as LIBRARY_OBJS
|