e4af234d3c
Fixes: - http://autobuild.buildroot.net/results/966a3de94aa97fa8e9895eede29c9cbfb4bd7301 .../host/lib/gcc/arm-buildroot-linux-musleabihf/9.3.0/../../../../arm-buildroot-linux-musleabihf/bin/ld: warning: libisccfg.so.163, needed by ../../lib/bind9/.libs/libbind9.so, not found (try using -rpath or -rpath-link) .../host/lib/gcc/arm-buildroot-linux-musleabihf/9.3.0/../../../../arm-buildroot-linux-musleabihf/bin/ld: ../../lib/bind9/.libs/libbind9.so: undefined reference to `cfg_obj_line' Signed-off-by: Peter Seiderer <ps.report@gmx.net> [Peter: replace by upstream patches] Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
From 5cec1ba2fa2f18e9d9e926eab923e0b1b7b8d226 Mon Sep 17 00:00:00 2001
|
|
From: Mark Andrews <marka@isc.org>
|
|
Date: Tue, 15 Dec 2020 19:18:41 +1100
|
|
Subject: [PATCH] Handle shared library platforms that don't support inter
|
|
library dependancies
|
|
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
---
|
|
bin/tools/Makefile.in | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/bin/tools/Makefile.in b/bin/tools/Makefile.in
|
|
index 6f984f121a..d34bac1192 100644
|
|
--- a/bin/tools/Makefile.in
|
|
+++ b/bin/tools/Makefile.in
|
|
@@ -94,9 +94,9 @@ genrandom@EXEEXT@: genrandom.@O@
|
|
${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} \
|
|
-o $@ genrandom.@O@ @GENRANDOMLIB@ ${LIBS}
|
|
|
|
-mdig@EXEEXT@: mdig.@O@ ${ISCDEPLIBS} ${DNSDEPLIBS} ${BIND9DEPLIBS}
|
|
+mdig@EXEEXT@: mdig.@O@ ${ISCDEPLIBS} ${DNSDEPLIBS} ${BIND9DEPLIBS} ${ISCCFGDEPLIBS}
|
|
export BASEOBJS="mdig.@O@"; \
|
|
- export LIBS0="${DNSLIBS} ${BIND9LIBS}"; \
|
|
+ export LIBS0="${BIND9LIBS} ${ISCCFGLIBS} ${DNSLIBS}"; \
|
|
${FINALBUILDCMD}
|
|
|
|
dnstap-read@EXEEXT@: dnstap-read.@O@ ${ISCDEPLIBS} ${DNSDEPLIBS}
|
|
--
|
|
2.20.1
|
|
|