df9244ff37
The current popt build system tests the existence of <glob.h>, and then assumes that if __GLIBC__ is defined, then glob_pattern_p() must be available. Unfortunately, that's not true with uClibc: <glob.h> may be installed, but not necessarily the GNU glob extensions... and uClibc defines __GLIBC__. This is causing build issues with certain uClibc toolchains that do not have GNU glob extensions enabled. To fix this, we introduce a patch called popt-03-glob-detection.patch which adds a new AC_CHECK_FUNCS() test for glob_pattern_p() and uses the result to know if this function is available, instead of testing __GLIBC__. In order for this patch to work, the popt package must be autoreconfigured, so another patch, popt-02-fix-autoreconf.patch, is needed to make the package autoreconfigure properly. And also POPT_AUTORECONF = YES is added to popt.mk. Finally, this change avoids the need for the Blackfin toolchain specific testing, which we forgot to update when introducing the 2014R1 version of the Blackfin toolchain. With this new solution, there will be no need to update the popt.mk file when new Blackfin toolchains are added. Fixes: http://autobuild.buildroot.org/results/e09/e09e24fec240382a3197fef3e98eb9a22f76420a/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Yuvaraj Patil <yuvaraj.patil@wipro.com> Cc: Sonic Zhang <sonic.zhang@analog.com>
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
Detect glob_pattern_p()
|
|
|
|
The current popt build system tests the existence of <glob.h>, and
|
|
then assumes that if __GLIBC__ is defined, then glob_pattern_p() must
|
|
be available. Unfortunately, that's not true with uClibc: <glob.h> may
|
|
be installed, but not necessarily the GNU glob extensions... and
|
|
uClibc defines __GLIBC__. This is causing build issues with certain
|
|
uClibc toolchains that do not have GNU glob extensions enabled.
|
|
|
|
To fix this, this patch adds an AC_CHECK_FUNCS() test for
|
|
glob_pattern_p, and uses that to find out whether glob_pattern_p() is
|
|
available or not.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -81,7 +81,7 @@
|
|
AC_CHECK_FUNC(setreuid, [], [
|
|
AC_CHECK_LIB(ucb, setreuid, [if echo $LIBS | grep -- -lucb >/dev/null ;then :; else LIBS="$LIBS -lc -lucb" USEUCB=y;fi])
|
|
])
|
|
-AC_CHECK_FUNCS(getuid geteuid iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom)
|
|
+AC_CHECK_FUNCS(getuid geteuid iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom glob_pattern_p)
|
|
|
|
AM_GNU_GETTEXT([external])
|
|
AM_ICONV_LINK
|
|
Index: b/poptconfig.c
|
|
===================================================================
|
|
--- a/poptconfig.c
|
|
+++ b/poptconfig.c
|
|
@@ -42,7 +42,7 @@
|
|
/*@=declundef =exportheader =incondefs =protoparammatch =redecl =type @*/
|
|
#endif /* __LCLINT__ */
|
|
|
|
-#if !defined(__GLIBC__)
|
|
+#if !defined(HAVE_GLOB_PATTERN_P)
|
|
/* Return nonzero if PATTERN contains any metacharacters.
|
|
Metacharacters can be quoted with backslashes if QUOTE is nonzero. */
|
|
static int
|