kumquat-buildroot/support/kconfig/patches/17-backport-kecho.patch
Petr Vorel 775087fab0 kconfig: Add missing patch
which was specified, but not added during last update.

Fixes: 6eacea5ae0 ("support/kconfig: bump to kconfig from Linux 4.17-rc2")

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2018-10-30 20:57:04 +01:00

27 lines
742 B
Diff

This commit added kecho to scripts/Kbuild.include (and doc).
Backported just Kbuild.include part to Makefile
commit 5410ecc0def8955ab99810c5626cc7e156991896
Author: Mike Frysinger <vapier@gentoo.org>
Date: Thu Nov 6 03:31:34 2008 -0500
kbuild: introduce $(kecho) convenience echo
Index: kconfig/Makefile
===================================================================
--- kconfig.orig/Makefile
+++ kconfig/Makefile
@@ -6,6 +6,12 @@
PHONY += xconfig gconfig menuconfig config syncconfig update-po-config \
localmodconfig localyesconfig
+# Easy method for doing a status message
+ kecho := :
+ quiet_kecho := echo
+silent_kecho := :
+kecho := $($(quiet)kecho)
+
ifdef KBUILD_KCONFIG
Kconfig := $(KBUILD_KCONFIG)
else