kumquat-buildroot/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch
Renaud AUBIN ba1b3a5f39 package/libhttpparser: New package
http-parser provides a simple C API to parse HTTP responses and
requests.

This packaging uses the official Joyent repository.

[Thomas:
 - since we're always building the shared library, depend on
   !BR2_STATIC_LIBS in Config.in. We could build only the static
   library, but then we would have to do all the lib installation
   manually.
 - indent using tabs in Config.in
 - use 'make install' instead of handcoding the library installation.
 - use $(TARGET_CONFIGURE_OPTS) instead of just CC= and LD=.
 - use tabs for indentation in commands instead of spaces
 - add patch to fix reinstallation.]

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-08-28 19:18:13 +02:00

35 lines
1.1 KiB
Diff

From d9dfeca8736318eaad5cd4554cbae059469decde Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Fri, 28 Aug 2015 19:02:11 +0200
Subject: [PATCH] Use -f option when calling ln at install time
This allows "make install; make install" to work properly.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 373709c..6206b09 100644
--- a/Makefile
+++ b/Makefile
@@ -113,12 +113,12 @@ tags: http_parser.c http_parser.h test.c
install: library
$(INSTALL) -D http_parser.h $(INCLUDEDIR)/http_parser.h
$(INSTALL) -D $(SONAME) $(LIBDIR)/$(SONAME)
- ln -s $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.so
+ ln -sf $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.so
install-strip: library
$(INSTALL) -D http_parser.h $(INCLUDEDIR)/http_parser.h
$(INSTALL) -D -s $(SONAME) $(LIBDIR)/$(SONAME)
- ln -s $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.so
+ ln -sf $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.so
uninstall:
rm $(INCLUDEDIR)/http_parser.h
--
2.5.0