a95c363809
Kodi 17 is incompatible with ffmpeg-4.x. To prepare the ffmpeg bump we switch the current Kodi package to internally build and statically link to patched ffmpeg-3.1.11 provided by upstream. Gnutls is added as dependency to allow playback of https streams. Upstream expects Kodi 17 to be used with ffmpeg 3.1.x (see upstream PR 12368) so we choose the upstream way to build ffmpeg instead of provi- ding a version choice for ffmpeg in buildroot. This commit can be reverted when Kodi is bumped to version 18, currently released as alpha3. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
82 lines
4.9 KiB
Diff
82 lines
4.9 KiB
Diff
From d2c343a20bb61098d0450b15ea2d1dacd28d954a Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Sun, 12 Aug 2018 15:13:24 +0200
|
|
Subject: [PATCH] Fix crosscompiling issues
|
|
|
|
The codepath for KODI_DEPENDSBUILD needs to be used in order to provide
|
|
the correct crosscompiling options to ffmpeg. The CMake option
|
|
KODI_DEPENDSBUILD itself can not be enabled because it disables the
|
|
internal build of libdvd*.
|
|
|
|
To link kodi.bin with the statically built ffmpeg libraries kodi uses
|
|
a wrapper script which calls pkgconfig. Our pkgconfig is patched to
|
|
alter paths which breaks the link command in this case, to fix this
|
|
PKG_CONFIG_SYSROOT_DIR was added.
|
|
|
|
Also remove configure option --cpu from ffmpeg_conf to fix build
|
|
errors.
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
project/cmake/modules/FindFFMPEG.cmake | 16 +++++++---------
|
|
tools/depends/target/ffmpeg/CMakeLists.txt | 2 +-
|
|
2 files changed, 8 insertions(+), 10 deletions(-)
|
|
|
|
diff --git a/project/cmake/modules/FindFFMPEG.cmake b/project/cmake/modules/FindFFMPEG.cmake
|
|
index 28cc80710e..1ac8793149 100644
|
|
--- a/project/cmake/modules/FindFFMPEG.cmake
|
|
+++ b/project/cmake/modules/FindFFMPEG.cmake
|
|
@@ -233,16 +233,14 @@ if(NOT FFMPEG_FOUND)
|
|
message(STATUS "FFMPEG_URL: ${FFMPEG_URL}")
|
|
endif()
|
|
|
|
- if(KODI_DEPENDSBUILD)
|
|
set(CROSS_ARGS -DDEPENDS_PATH=${DEPENDS_PATH}
|
|
-DPKG_CONFIG_EXECUTABLE=${PKG_CONFIG_EXECUTABLE}
|
|
-DCROSSCOMPILING=${CMAKE_CROSSCOMPILING}
|
|
-DCMAKE_TOOLCHAIN_FILE=${CMAKE_TOOLCHAIN_FILE}
|
|
- -DOS=${OS}
|
|
+ -DOS=linux
|
|
-DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
|
|
-DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
|
|
-DCMAKE_AR=${CMAKE_AR})
|
|
- endif()
|
|
|
|
externalproject_add(ffmpeg
|
|
URL ${FFMPEG_URL}
|
|
@@ -270,12 +268,12 @@ if(NOT FFMPEG_FOUND)
|
|
"#!/bin/bash
|
|
if [[ $@ == *${APP_NAME_LC}.bin* || $@ == *${APP_NAME_LC}.so* || $@ == *${APP_NAME_LC}-test* ]]
|
|
then
|
|
- avformat=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavcodec`
|
|
- avcodec=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavformat`
|
|
- avfilter=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavfilter`
|
|
- avutil=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavutil`
|
|
- swscale=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libswscale`
|
|
- swresample=`PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libswresample`
|
|
+ avformat=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavcodec`
|
|
+ avcodec=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavformat`
|
|
+ avfilter=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavfilter`
|
|
+ avutil=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libavutil`
|
|
+ swscale=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libswscale`
|
|
+ swresample=`PKG_CONFIG_SYSROOT_DIR=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR} PKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig ${PKG_CONFIG_EXECUTABLE} --libs --static libswresample`
|
|
gnutls=`PKG_CONFIG_PATH=${DEPENDS_PATH}/lib/pkgconfig/ ${PKG_CONFIG_EXECUTABLE} --libs-only-l --static --silence-errors gnutls`
|
|
$@ $avcodec $avformat $avcodec $avfilter $swscale $swresample -lpostproc $gnutls
|
|
else
|
|
diff --git a/tools/depends/target/ffmpeg/CMakeLists.txt b/tools/depends/target/ffmpeg/CMakeLists.txt
|
|
index fda6b0cac4..af3afa6b60 100644
|
|
--- a/tools/depends/target/ffmpeg/CMakeLists.txt
|
|
+++ b/tools/depends/target/ffmpeg/CMakeLists.txt
|
|
@@ -9,7 +9,7 @@ set(ffmpeg_conf "")
|
|
if(CROSSCOMPILING)
|
|
set(pkgconf "PKG_CONFIG_LIBDIR=${DEPENDS_PATH}/lib/pkgconfig")
|
|
list(APPEND ffmpeg_conf --pkg-config=${PKG_CONFIG_EXECUTABLE} --pkg-config-flags=--static)
|
|
- list(APPEND ffmpeg_conf --enable-cross-compile --cpu=${CPU} --arch=${CPU} --target-os=${OS})
|
|
+ list(APPEND ffmpeg_conf --enable-cross-compile --arch=${CPU} --target-os=${OS})
|
|
list(APPEND ffmpeg_conf --cc=${CMAKE_C_COMPILER} --cxx=${CMAKE_CXX_COMPILER} --ar=${CMAKE_AR})
|
|
message(STATUS "CROSS: ${ffmpeg_conf}")
|
|
endif()
|
|
--
|
|
2.18.0
|
|
|