kumquat-buildroot/package/freeradius-server/0001-jlibtool-cross-with-host-CC.patch
David GOUARIN 736c4c1655 package/freeradius-server: new package
FreeRADIUS is an open source server which implements
a protocol for remote user Authorization, Authentication
and Accounting.

There are many modules. All modules without dependencies are enabled.
The modules with a dependency that we have are automatically enabled if
the dependency is enabled. Modules with dependencies we don't support
are explicitly disabled.

The configure script always looks in host directories for libraries, so
it is essential to explicitly disable everything that is not actually
provided.

Signed-off-by: David GOUARIN <dgouarin@gmail.com>
Signed-off-by: Kalpesh Panchal <kalpesh.panchal@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@collins.com>
[Arnout:
 - remove second patch, superseded by other patches;
 - add upstream links to patches;
 - add more patches to avoid looking in host directories;
 - explicitly add dependency on !static inherited from talloc (redundant
   with glibc, but future-safe);
 - simplify Config.in comment;
 - check hash with PGP signature;
 - add conf opts for runtime paths;
 - add conf opts to disable unsupported modules;
 - add more optional dependencies;
 - enable/disable all modules that use a dependency;
 - search defaults file in /etc/default, not /etc/sysconfig.
]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2022-07-26 19:52:18 +02:00

34 lines
939 B
Diff

From 8a8506320acf3ea18940a6e3a447d7d394a3bd8e Mon Sep 17 00:00:00 2001
From: David Gouarin <david.gouarin@thalesgroup.com>
Date: Mon, 12 Apr 2021 11:05:54 -0500
Subject: [PATCH] jlibtool cross with host CC
jlibtool.c: while cross compiling, use host CC instead of target CC to build jlibtool
Upstream: Not applicable
Signed-off-by: David Gouarin <david.gouarin@thalesgroup.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
---
scripts/libtool.mk | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/libtool.mk b/scripts/libtool.mk
index 57915e1053..c28260dd7e 100644
--- a/scripts/libtool.mk
+++ b/scripts/libtool.mk
@@ -43,8 +43,8 @@ ifeq "${LIBTOOL}" "JLIBTOOL"
# binary!
${JLIBTOOL}: ${top_makedir}/jlibtool.c
$(Q)mkdir -p $(dir $@)
- $(Q)echo CC jlibtool.c
- $(Q)${CC} $< -o $@
+ $(Q)echo HOSTCC jlibtool.c
+ $(Q)${HOSTCC} $< -o $@
clean: jlibtool_clean
--
2.17.1